Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
17 июн 2024, 12:26

При нажатии на поле в строке прыгает таблица в 8.3

Автор Mihail152, 11 апр 2020, 23:17

0 Пользователей и 1 гость просматривают эту тему.

Mihail152

Добрый день,
при открытии управляемой формы пользователем и проматывании вниз или бок(количество рабочих дней и фио работников) нажимая на поле таблицы для  редактирования данных видим резкий скачок строки работника на середину экрана и так происходит у всех пользователей при редакции работников разных подразделений

прошу помочь, может кто то решал уже подобное...

Поиск родных

Наименование конфигурации и версия - какие?

Mihail152

Зарплата и управление персоналом, редакция 3.1 (3.1.12.142)


1С:Предприятие 8.3 (8.3.15.1747)

antoneus

А что в обработчике активизации строки там делается?

Mihail152

Цитата: antoneus от 15 апр 2020, 23:31А что в обработчике активизации строки там делается?

Спасибо, что спросили)

&НаКлиенте
Процедура ДанныеПриАктивизацииСтроки(Элемент)
    Если не Элементы.Данные.ТекущиеДанные = Неопределено Тогда
        Если не Элементы.СотрудникЗакрыт.Видимость Тогда
            Элементы.СотрудникЗакрыт.Видимость = Истина;
        КонецЕсли;
        ТекущиеДанные = Элементы.Данные.ТекущиеДанные;
        Если не ТекущийСотрудник = ТекущиеДанные.Сотрудник Тогда
            ТекущийСотрудник = ТекущиеДанные.Сотрудник;
            Элементы.СотрудникЗакрыт.Заголовок = Строка(ТекущийСотрудник)+", "+?(ТекущиеДанные.ЗапретРедактирования," доступ закрыт","доступ открыт");
            СотрудникЗакрыт = ?(ТекущиеДанные.ЗапретРедактирования,1,0);
        КонецЕсли;
    Иначе
        Элементы.СотрудникЗакрыт.Видимость = Ложь;
    КонецЕсли;           
КонецПроцедуры

antoneus

Обновление данных на форме = неявный вызов сервера = прыжок текущей строки в центр. Вызывайте в обработчике активизации оповещение, в обработке которого обновляйте инфу или включайте обработчик ожидания с вызовом процедуры обновления инфы.
И запоминайте текущую строку и при обновлении проверяйте - поменялась она или осталась прежней.

Mihail152

Цитата: antoneus от 26 апр 2020, 00:52
Обновление данных на форме = неявный вызов сервера = прыжок текущей строки в центр. Вызывайте в обработчике активизации оповещение, в обработке которого обновляйте инфу или включайте обработчик ожидания с вызовом процедуры обновления инфы.
И запоминайте текущую строку и при обновлении проверяйте - поменялась она или осталась прежней.

Спасибо,за четкий ответ и верное направление!
Можете подсказать , где нибудь описано как это делать или показать пример?

antoneus

Так, с декорацией я немножко обманул - при обновлении заголовка в любом случае строчка будет прыгать в центр. Если добавить реквизит формы и вытащить его на форму как поле надписи и при активизации строки обновлять значение реквизита - все будет красиво.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск