Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 фев 2024, 00:00

Прошу помощи... реквизиты, справочники, документ

Автор MasSseL, 29 апр 2011, 11:56

0 Пользователей и 1 гость просматривают эту тему.

MasSseL

Привет всем.
У меня такая проблемма.
У меня есть справочник- АнкетаКлиента. И соответственно 3 поля в нем: ФИО, Паспорт, Адрес.
Создаю документ допустим -ДоговорГараж(не столь важно название).
В Форме этого документа создаю реквизиты ФИО, Паспорт, Адрес ... и так далее. Реквизит ФИО тип:делаю ссылку на Справочник.АнкетаКлиента.

Все ясно. !!

Вот, что у меня не получается. На форме этого документа соответственно поля. При нажатии на поле ФИО, у меня открывается Справочник АнкетаКлиента (и в реквизит документа ФИО переносится значение справочника). А как сделать чтобы при этом заполнялись соответственно и другие реквизиты документа??? (всмысле только при выборе ФИО) :trhregerhg:

Вот такая вот проблемка.
Спасибо все заранее.
Не гневайтесь за мои порой тупые вопросы, я ведь только учусь!!!

MasSseL

Не гневайтесь за мои порой тупые вопросы, я ведь только учусь!!!

MasSseL

Цитата: sergejK74 от 29 апр 2011, 13:10
Для поля ФИО в событи ПриИзменении вставляешь обращение к серверной функции, где запросом или выборкой получаешь нужные данные. Записываешь их в реквизиты. Вот так кратко.

так вот в этом вся и загвоздка... событие ПриИзменении я сделал... а как дальше все описать я не могу разобраться... перерыл кучу форумов... там все описывается процедура обращения к табличной части а не к реквизитам
Не гневайтесь за мои порой тупые вопросы, я ведь только учусь!!!

MasSseL

Сделал на подобии примера по ссылке....
общий модуль:
Функция ПолучитьПараметрыКонтагента(Контрагент) Экспорт
   
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |    АнкетаКлиента.Паспорт,
         |ИЗ
        |    Справочник.АнкетаКлиента КАК АнкетаКлиента
        |ГДЕ
        |    АнкетаКлиента.Ссылка = &Ссылка";

    Запрос.УстановитьПараметр("Ссылка", Контрагент);

    Результат = Запрос.Выполнить();

    ВыборкаДетальныеЗаписи = Результат.Выбрать();

    СписокПараметров = Новый Структура;
   
СписокПараметров.Вставить("Паспорт");

Если ВыборкаДетальныеЗаписи.Следующий() Тогда
       
СписокПараметров.Паспорт = ВыборкаДетальныеЗаписи.Паспорт;
       
    КонецЕсли;

    Возврат СписокПараметров;   

КонецФункции

модуль формы документа:
&НаКлиенте
Процедура ФИОПриИзменении(Элемент)
    Парам = ПодсчетыИПодстановки.ПолучитьПараметрыКонтагента(Объект.ФИО);
   Объект.Паспорт = Парам.Паспорт;
КонецПроцедуры

ругается:
{Документ.ДоговорНаКвартиру.Форма.ФормаДокумента.Форма(3,13)}: Переменная не определена (ПодсчетыИПодстановки)
    Парам = <<?>>ПодсчетыИПодстановки.ПолучитьПараметрыКонтагента(Объект.ФИО); (Проверка: Тонкий клиент)

в чем загвоздка???
Не гневайтесь за мои порой тупые вопросы, я ведь только учусь!!!

MasSseL

ругается:
ЗаполнитьЗначенияСвойств(СтруктураДанных, <<?>>Контрагент); (Проверка: Сервер)
{Документ.ДоговорНаКвартиру.Форма.ФормаДокумента.Форма(6,11)}: Переменная не определена (СтруктураДанныхКонтрагента)
Паспорт = <<?>>СтруктураДанныхКонтрагента.Паспорт; (Проверка: Тонкий клиент)
{Документ.ДоговорНаКвартиру.Форма.ФормаДокумента.Форма(7,9)}: Переменная не определена (СтруктураДанныхКонтрагента)
Адрес = <<?>>СтруктураДанныхКонтрагента.Адрес; (Проверка: Тонкий клиент)
Не гневайтесь за мои порой тупые вопросы, я ведь только учусь!!!

MasSseL

так наверное у меня путанница с "Контрагент"
у меня документ ДоговорКвартира... реквизит "ФИО" процедура ФИОПриИзменении(Элемент)
справочник называется АнкетаКлиента... в нем реквизиты ФИО... Паспорт...
Не гневайтесь за мои порой тупые вопросы, я ведь только учусь!!!

MasSseL

уже все без ошибок... но ничего не происходит(( ФИО выбирается .. а поле паспорт остается пустым((
Не гневайтесь за мои порой тупые вопросы, я ведь только учусь!!!

MasSseL

ОГРОМНОЕ спасибо... но самое интересное в том, что у меня был написан один в один текст с последним и он не работал... а сейчас просто скопировал и заменил на последний и все получилось... мистика)))
Не гневайтесь за мои порой тупые вопросы, я ведь только учусь!!!

MasSseL

Не гневайтесь за мои порой тупые вопросы, я ведь только учусь!!!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск