Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
22 июл 2024, 21:04

Передача значения реквизита при открытии формы

Автор Алексей_1985_06, 01 фев 2020, 22:31

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Ребят подскажите как при открытии формы документа из формы справочника, передать в реквизит открываемого документа "ФамилияИмяОтчество", ФамилиюИмяОтчество записанное в реквизит этого справочника?

Что нужно дописать в коде:

&НаКлиенте
Процедура ЗаписьПаспорта(Команда)
ОткрытьФорму("Документ.ИзмененияПаспортныхДанных.ФормаОбъекта");
КонецПроцедуры

alexandr_ll

Цитата: Алексей_1985_06 от 01 фев 2020, 22:31
Ребят подскажите как при открытии формы документа из формы справочника, передать в реквизит открываемого документа "ФамилияИмяОтчество", ФамилиюИмяОтчество записанное в реквизит этого справочника?

Что нужно дописать в коде:

&НаКлиенте
Процедура ЗаписьПаспорта(Команда)
ОткрытьФорму("Документ.ИзмененияПаспортныхДанных.ФормаОбъекта");
КонецПроцедуры

Скорее всего вы хотите передать в документ не ФИО, а ссылку на элемент справочника. Добавьте ссылку в параметры метода "Открыть форму", она будет доступна в модуле формы при создании на сервере.

Алексей_1985_06

Цитата: alexandr_ll от 02 фев 2020, 06:01
Цитата: Алексей_1985_06 от 01 фев 2020, 22:31
Ребят подскажите как при открытии формы документа из формы справочника, передать в реквизит открываемого документа "ФамилияИмяОтчество", ФамилиюИмяОтчество записанное в реквизит этого справочника?

Что нужно дописать в коде:

&НаКлиенте
Процедура ЗаписьПаспорта(Команда)
ОткрытьФорму("Документ.ИзмененияПаспортныхДанных.ФормаОбъекта");
КонецПроцедуры

Скорее всего вы хотите передать в документ не ФИО, а ссылку на элемент справочника. Добавьте ссылку в параметры метода "Открыть форму", она будет доступна в модуле формы при создании на сервере.

Нет, не совсем так... мне нужно при открытии формы документа (в нем есть реквизит ФИО) из формы справочника, в котором тоже есть реквизит ФИО - передать это значение в реквизит документа, что бы "ручками" его не записывать....

alexandr_ll

Цитата: Алексей_1985_06 от 02 фев 2020, 11:31
Цитата: alexandr_ll от 02 фев 2020, 06:01
Цитата: Алексей_1985_06 от 01 фев 2020, 22:31
Ребят подскажите как при открытии формы документа из формы справочника, передать в реквизит открываемого документа "ФамилияИмяОтчество", ФамилиюИмяОтчество записанное в реквизит этого справочника?

Что нужно дописать в коде:

&НаКлиенте
Процедура ЗаписьПаспорта(Команда)
ОткрытьФорму("Документ.ИзмененияПаспортныхДанных.ФормаОбъекта");
КонецПроцедуры

Скорее всего вы хотите передать в документ не ФИО, а ссылку на элемент справочника. Добавьте ссылку в параметры метода "Открыть форму", она будет доступна в модуле формы при создании на сервере.

Нет, не совсем так... мне нужно при открытии формы документа (в нем есть реквизит ФИО) из формы справочника, в котором тоже есть реквизит ФИО - передать это значение в реквизит документа, что бы "ручками" его не записывать....
А что не так? Если вы передадите в форму ссылку, то реквизит ФИО будет доступен по ссылке.
https://www.1s-up.ru/otkrytie-upravljaemoj-formy-v-1s-8-3-s-peredachej-parametrov/

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск