Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
17 июн 2024, 12:39

Поиск в докуенте по всем реквизитам.

Автор Isandersam, 21 апр 2011, 14:35

0 Пользователей и 1 гость просматривают эту тему.

Isandersam

Подскажите пожалуйста: пример поиска по всем реквизитам. Одна строчка, вводим текст и ищет во всем документе по заданным полям. Если находит то выводит в таблицу. Спасибо заранее.

has

Поиск по метаданным документа чтоли?

Isandersam

С большим удовольствием по читаю! :) Ещё бы ссылочку.

Maxim


Maxim

в обычной или управляемой форме? запрос или цикл?

Maxim

Попробуй так:
ТаблицаЗначений = Новый ТаблицаЗначений;
ТаблицаЗначений.Колонки.Добавить("Документ");
Для каждого Документ Из Метаданные.Документы Цикл
   ПризнакНахождения = Ложь;
   Для каждого Реквизит Из Документ.Реквизиты Цикл
      Если ТипЗнч(Реквизит) = Тип("Строка") Тогда
         Если Реквизит = "Isandersam" Тогда         
            ПризнакНахождения = Истина;
         КонецЕсли;
      КонецЕсли;
   КонецЦикла;
   Если ПризнакНахождения = Истина Тогда
      ТаблицаЗначений.Добавить();
      ТаблицаЗначений.Документ = Документ.Ссылка;
   КонецЕсли;
КонецЦикла;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск