Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 мар 2024, 19:59

Как скопировать реквизит из одного документа в другой

Автор Reveluv, 27 дек 2018, 12:43

0 Пользователей и 1 гость просматривают эту тему.

Reveluv

Здравствуйте! Я новичок в 1С, у меня учебная задача, собственная конфигурация.
Есть документ "Индивидуальный заказ" с тч "Заказ". На документе есть кнопка, при нажатии на которую, создаются документы "Конкретное изделие в заказе". Сколько строк в тч, столько и создается документов. Вопрос в том, как перенести реквизит Сумма Документа из документа "Конкретное изделие" в тч документа "Индивидуальный заказ"? Подскажите, в каком направлении идти?
Со второй картинки суммы нужно скопировать на первую. При этом, чтобы они не перепутались


wise

Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Reveluv

Цитата: wise от 27 дек 2018, 14:42
(0) покажи код создания документов.
На форме документа "Индивидуальный заказ"
&НаКлиенте
Процедура КонкретноеИзделие(Команда)
НовДок = СоздатьДокументНаСервере();
КонецПроцедуры


&НаСервере
Функция СоздатьДокументНаСервере()
Для Каждого ТекущаяСтрока Из Объект.Заказ Цикл
    НовДок = Документы.КонкретноеИзделиеВЗаказе.СоздатьДокумент();
    НовДок.Дата = ТекущаяДата();
    НовДок.КодЗаказа = Объект.Номер;
    НовДок.КодИзделияВЗаказе = ТекущаяСтрока.КодИзделия;
    НовДок.НаименованиеИзделия = ТекущаяСтрока.НаименованиеИзделия;   
    РазИзд = НовДок.ОсновноеИзделие.добавить(); 
    РазИзд.Размер = ТекущаяСтрока.Размер;
    НовДок.Записать();
КонецЦикла;
КонецФункции

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск