Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 апр 2024, 01:49

ЧТО НАДО НАПИСАТЬ К ПУСТОЙ ССЫЛКЕ (см. в коде)

Автор Dikova, 30 окт 2018, 20:38

0 Пользователей и 1 гость просматривают эту тему.

Dikova

Процедура ЗаполнитьТаблицуПлатежей(Элемент)
   Список=Новый СписокЗначений;
   
       Если Платежи.Количество()>0 Тогда
           Для КАждого жж Из Платежи Цикл         
            Список.Добавить(жж.ПоступлениеДенег);
           КонецЦикла;
       КонецЕсли;
Док=Документы.ПоступлениеНаРасчетныйСчет;
     НашиПлатежи=Док.Выбрать();
     Пока НашиПлатежи.Следующий() Цикл
        Если НашиПлатежи.Контрагент <> Заказчик Тогда
           Продолжить;
        КонецЕсли;
       
         Если НашиПлатежи.Проведен = Ложь Тогда
           Продолжить;
        КонецЕсли;
         
         
           Если НашиПлатежи.Контрагент.Ссылка=Заказчик Тогда
             Точка=0;
              Если НашиПлатежи.ДоговорКонтрагента=ГлавныйДоговор Тогда
                РезПоиска=Список.НайтиПоЗначению(НашиПлатежи.Ссылка);
                Если РезПоиска=Неопределено Тогда
                     Запись=Платежи.Добавить();
                    Запись.ПоступлениеДенег=НашиПлатежи.Ссылка;
                  Запись.Сумма=НашиПлатежи.СуммаДокумента;
                  Запись.ДатаПлатежа=НашиПлатежи.Дата;
               ИНаче
                  Сообщить("Найденный документ уже в списке!");
                  КонецЕсли;
           КонецЕсли;
        КонецЕсли;
       
      
   // что здесь надо прикрепить к пустой ссылке

Если             .ПустаяСсылка() Тогда                 
   суб1=НашиПлатежи.СубконтоКт1;
   суб2=НашиПлатежи.СубконтоКт2;

          ИмяПеречисления1=суб1.Метаданные().Имя;
          ИмяПеречисления2=суб2.Метаданные().Имя;
Если ИмяПеречисления2= "ДоговорыКонтрагентов"  Тогда
             РезПоиска=Список.НайтиПоЗначению(НашиПлатежи.Ссылка);
                Если РезПоиска=Неопределено Тогда
                     Запись=Платежи.Добавить();
                    Запись.ПоступлениеДенег=НашиПлатежи.Ссылка;
                  Запись.Сумма=НашиПлатежи.СуммаДокумента;
                  Запись.ДатаПлатежа=НашиПлатежи.Дата;
               ИНаче
                  Сообщить("Найденный документ уже в списке!");
                  КонецЕсли;
           КонецЕсли;
Если ИмяПеречисления1= "ДоговорыКонтрагентов"Тогда

РезПоиска=Список.НайтиПоЗначению(НашиПлатежи.Ссылка);
                Если РезПоиска=Неопределено Тогда
                     Запись=Платежи.Добавить();
                    Запись.ПоступлениеДенег=НашиПлатежи.Ссылка;
                  Запись.Сумма=НашиПлатежи.СуммаДокумента;
                  Запись.ДатаПлатежа=НашиПлатежи.Дата;
               ИНаче
                  Сообщить("Найденный документ уже в списке!");
                  КонецЕсли;
           КонецЕсли;

                    

       КонецЦикла;
            
   
   
                 
    КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск