Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
17 апр 2024, 23:52

Запись результата выборки в поле справочник

Автор Мария Петерикова, 12 окт 2018, 15:17

0 Пользователей и 1 гость просматривают эту тему.

Мария Петерикова

Всем привет. Не кидайтесь пож тапками, я только учусь
Задача - есть справочник, в его форме есть два поля, одно заполненно, второе нет. Необходимо заполнить второе значением первого.

Сделала внешнюю обработку:

Процедура КнопкаВыполнитьНажатие(Кнопка)
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   НомераГТД.Код,
      |   НомераГТД.РегистрационныйНомер
      |ИЗ
      |   Справочник.НомераГТД КАК НомераГТД";
   
   Выборка = Запрос.Выполнить().Выбрать();
     
   Пока Выборка.Следующий() Цикл
   Объект = Выборка.Ссылка.ПолучитьОбъект();
   Объект = Объект.НомераГТД.РегистрационныйНомер;
   Объект.Записать();
   КонецЦикла;

КонецПроцедуры

Ошибка метод объекта не обнаружен
помогите пожалуйста :(:(

KOI8-R


АлександрВладимирович

Выбирать надо Ссылку. А еще Объект - не самое удачное имя для переменной.

   Запрос = Новый Запрос;
   Запрос.Текст =
   "ВЫБРАТЬ
   |   НомераГТД.Ссылка
   |ИЗ
   |   Справочник.НомераГТД КАК НомераГТД";
   
   Выборка = Запрос.Выполнить().Выбрать();
   
   Пока Выборка.Следующий() Цикл
      СправочникОбъект = Выборка.Ссылка.ПолучитьОбъект();
      СправочникОбъект.ПолеКотороеНадоЗаполнить = СправочникОбъект.ПолеКотороеУжеЗаполнено;
      СправочникОбъект.Записать();
   КонецЦикла;

Теги: выборки 

Похожие темы (5)

Рейтинг@Mail.ru

Поиск