Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 апр 2024, 15:36

доступ к сетевому диску с клиент-серверной базы

Автор NAPYTO1613, 08 окт 2018, 18:36

0 Пользователей и 1 гость просматривают эту тему.

NAPYTO1613

у меня есть условная обработка
в которой есть кнопка с действием

&НаКлиенте
Процедура Команда1 (Команда)
     Команда1НаСервере ();   
КонецПроцедуры

&НаСервере
Процедура Команда1НаСервере ()
    Массив = Новый Массив;
    Массив = НайтиФайлы("\\192.168.11.11\papka", .*);
    Для каждого элемент из массив цикл
        сообщить(элемент);
    КонецЦикла;
КонецПроцедуры



на локальной базе все отрабатывает нормально
на серверной базе же он ничего не возвращает
может быть ли проблема в чем-нибудь, кроме прав доступа ?

Golickoff

Этот сетевой путь открывается с сервера в проводнике?
Правило поведения на форуме №6: Не следует пытаться привлечь внимание к своему сообщению ... рассылкой персональных сообщений и/или электронных писем отдельным участникам форума с просьбой ответить в теме.

NAPYTO1613


Каримдат

НайтиФайлы (FindFiles)
Синтаксис:

НайтиФайлы(<Путь>, <Маска>, <ИскатьВПодкаталогах>)
Параметры:

<Путь> (обязательный)

Тип: Строка.
Путь к каталогу, в котором производится поиск. Каталог может быть как на локальной сети, так и на ftp-сервере. При использовании этой схемы в адресах необходимо указывать прямые слеши '/', а не обратные '\'.

Похожие темы (5)

Рейтинг@Mail.ru

Поиск