Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 апр 2024, 11:59

Свойства табличной части

Автор skillful, 05 окт 2018, 19:26

0 Пользователей и 1 гость просматривают эту тему.

skillful

См. скриншот. Сейчас в табличной части если щелкнуть 2 раза на какой-нибудь "Документ основание", можно увидеть значек лупы, нажав на который попадаешь сразу в этот самый документ. Но, всю табличную  часть нужно сделать не доступной для редактирования. Ставлю в свойствах табличной части галочку "Только просмотр", табличная часть не редактируется, но и если кликать по документу, то значек лупы не появляется, а надо, чтобы появлялся. Как победить этот недуг??

AIFrame

У тч по событию выбора;

СтандартнаяОбработка = Ложь;
ТД = ЭлементыФормы.ТЧ.ТекущиеДанные;
Если ТД = неопределено Тогда
    Возврат;
КонецЕсли;
Если Документы.ТипВсеСсылки().СодержитТип(ТипЗнч(ТД[Колонка.Имя]))
    ИЛИ Справочники.ТипВсеСсылки().СодержитТип(ТипЗнч(ТД[Колонка.Имя])) Тогда
    Попытка
        ОткрытьЗначение(ТД[Колонка.Имя].Ссылка);
    Исключение
        //Сообщить(ОписаниеОшибки()); // - если надо
    КонецПопытки;
КонецЕсли;

skillful

Цитата: AIFrame от 05 окт 2018, 20:53
У тч по событию выбора;

СтандартнаяОбработка = Ложь;
ТД = ЭлементыФормы.ТЧ.ТекущиеДанные;
Если ТД = неопределено Тогда
    Возврат;
КонецЕсли;
Если Документы.ТипВсеСсылки().СодержитТип(ТипЗнч(ТД[Колонка.Имя]))
    ИЛИ Справочники.ТипВсеСсылки().СодержитТип(ТипЗнч(ТД[Колонка.Имя])) Тогда
    Попытка
        ОткрытьЗначение(ТД[Колонка.Имя].Ссылка);
    Исключение
        //Сообщить(ОписаниеОшибки()); // - если надо
    КонецПопытки;
КонецЕсли;

Спасибо...

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск