Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 апр 2024, 11:01

Передать массив на форму.

Автор trialex3, 05 окт 2018, 13:02

0 Пользователей и 1 гость просматривают эту тему.

trialex3

Добрый день. Прошу помощи. Как можно  передать массив с ссылками на форму и отобразить их в списке значений? Через параметр массив не отправляется.

KOI8-R

Если форма открывается, тогда через параметры, если уже открыта, то через оповещение.

trialex3

Цитата: KOI8-R от 05 окт 2018, 13:10
Если форма открывается, тогда через параметры, если уже открыта, то через оповещение.

Через параметры не получается:
&НаКлиенте
Процедура НомераСписком(Команда)
МассивЭлементов = НеверныеНомера.ВыгрузитьЗначения();
СтруктураОтбора = Новый Структура;
СтруктураОтбора.Вставить("МассивПараметр", МассивЭлементов);

ПараметрФормы = Новый Структура;
ПараметрФормы.Вставить("Отбор", СтруктураОтбора);

ОткрытьФорму("Обработка.АР_РаботаСИзделиями.Форма.ФормаСпискаНепрНомеров", ПараметрФормы);

КонецПроцедуры


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Если Параметры.Свойство("МассивПараметр") Тогда
Массив = Параметры.МассивПараметр;
Для каждого Элемент Из Массив Цикл
СписокИзделий.Добавить(Элемент);
КонецЦикла;
КонецЕсли;
КонецПроцедуры


KOI8-R

Процедура НомераСписком(Команда)
МассивЭлементов = НеверныеНомера.ВыгрузитьЗначения();

ПараметрФормы = Новый Структура;
ПараметрФормы.Вставить("МассивПараметр", МассивЭлементов);

ОткрытьФорму("Обработка.АР_РаботаСИзделиями.Форма.ФормаСпискаНепрНомеров", ПараметрФормы);

Теги:  

Похожие темы (5)

Рейтинг@Mail.ru

Поиск