Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 апр 2024, 11:27

Преобразование значения к типу Число не может быть выполнено

Автор vtaa05, 05 окт 2018, 08:50

0 Пользователей и 1 гость просматривают эту тему.

vtaa05

Помогите разобраться. Не печатает читательский билет, выдает ошибку Преобразование значения к типу Число не может быть выполнено
Конфигуратор выдал ошибку в 24 строке
// ФОРМИРОВАНИЕ ШТРИХ-КОДОВ

// Функция вычисляет контрольный символ кода EAN
//
// Параметры:
//  ШтрихКод     - штрихкод (без контрольной цифры)
//  Тип          - тип штрихкода: 13 - EAN13, 8 - EAN8
//
// Возвращаемое значение:
//  Контрольный символ штрихкода
//
Функция КонтрольныйСимволEAN(ШтрихКод, Тип) Экспорт

   Четн   = 0;
   Нечетн = 0;

   КоличествоИтераций = ?(Тип = 13, 6, 4);

   Для Индекс = 1 По КоличествоИтераций Цикл
      Если (Тип = 8) и (Индекс = КоличествоИтераций) Тогда
      Иначе
         Четн   = Четн   + Число(Сред(ШтрихКод, 2 * Индекс, 1));
      КонецЕсли;
      Нечетн = Нечетн + Число(Сред(ШтрихКод, 2 * Индекс - 1, 1));
   КонецЦикла;

   Если Тип = 13 Тогда
      Четн = Четн * 3;
   Иначе
      Нечетн = Нечетн * 3;
   КонецЕсли;

   КонтЦифра = 10 - (Четн + Нечетн) % 10;

   Возврат ?(КонтЦифра = 10, "0", Строка(КонтЦифра));

КонецФункции // КонтрольныйСимволEAN()


alexandr_ll

Цитата: vtaa05 от 05 окт 2018, 08:50
Помогите разобраться. Не печатает читательский билет, выдает ошибку Преобразование значения к типу Число не может быть выполнено
Конфигуратор выдал ошибку в 24 строке
// ФОРМИРОВАНИЕ ШТРИХ-КОДОВ

// Функция вычисляет контрольный символ кода EAN
//
// Параметры:
//  ШтрихКод     - штрихкод (без контрольной цифры)
//  Тип          - тип штрихкода: 13 - EAN13, 8 - EAN8
//
// Возвращаемое значение:
//  Контрольный символ штрихкода
//
Функция КонтрольныйСимволEAN(ШтрихКод, Тип) Экспорт

   Четн   = 0;
   Нечетн = 0;

   КоличествоИтераций = ?(Тип = 13, 6, 4);

   Для Индекс = 1 По КоличествоИтераций Цикл
      Если (Тип = 8) и (Индекс = КоличествоИтераций) Тогда
      Иначе
         Четн   = Четн   + Число(Сред(ШтрихКод, 2 * Индекс, 1));
      КонецЕсли;
      Нечетн = Нечетн + Число(Сред(ШтрихКод, 2 * Индекс - 1, 1));
   КонецЦикла;

   Если Тип = 13 Тогда
      Четн = Четн * 3;
   Иначе
      Нечетн = Нечетн * 3;
   КонецЕсли;

   КонтЦифра = 10 - (Четн + Нечетн) % 10;

   Возврат ?(КонтЦифра = 10, "0", Строка(КонтЦифра));

КонецФункции // КонтрольныйСимволEAN()
Возможно в параметр функции "Тип" передается пустое значение

vtaa05

Цитата: alexandr_ll от 05 окт 2018, 08:57

Возможно в параметр функции "Тип" передается пустое значение
Как исправить?

alexandr_ll

Цитата: vtaa05 от 05 окт 2018, 08:59
Цитата: alexandr_ll от 05 окт 2018, 08:57

Возможно в параметр функции "Тип" передается пустое значение
Как исправить?
Не обращаться к функции, если тип не задан.

vtaa05

Цитата: alexandr_ll от 05 окт 2018, 08:57

Возможно в параметр функции "Тип" передается пустое значение
У меня проблема со штрих-кодами они на читательских билетах не формируются.
Если я задаю вариант формирования штрих-кода "Системная идентификация", то выдает такую ошибку
{ОбщийМодуль.ШтрихКодыСервер.Модуль(439)}: Ошибка при вызове метода контекста (Выполнить)
         Выборка = Запрос.Выполнить().Выбрать();
по причине:
{(9, 36)}: Синтаксическая ошибка "___________%""
И РегШтрихКоды.Штрихкод ПОДОБНО ""<<?>>___________%"

alexandr_ll

Цитата: vtaa05 от 05 окт 2018, 09:20
Цитата: alexandr_ll от 05 окт 2018, 08:57

Возможно в параметр функции "Тип" передается пустое значение
У меня проблема со штрих-кодами они на читательских билетах не формируются.
Если я задаю вариант формирования штрих-кода "Системная идентификация", то выдает такую ошибку
{ОбщийМодуль.ШтрихКодыСервер.Модуль(439)}: Ошибка при вызове метода контекста (Выполнить)
         Выборка = Запрос.Выполнить().Выбрать();
по причине:
{(9, 36)}: Синтаксическая ошибка "___________%""
И РегШтрихКоды.Штрихкод ПОДОБНО ""<<?>>___________%"
Что за конфигурация?

vtaa05

Цитата: alexandr_ll от 05 окт 2018, 09:25
Цитата: vtaa05 от 05 окт 2018, 09:20
Цитата: alexandr_ll от 05 окт 2018, 08:57

Возможно в параметр функции "Тип" передается пустое значение
У меня проблема со штрих-кодами они на читательских билетах не формируются.
Если я задаю вариант формирования штрих-кода "Системная идентификация", то выдает такую ошибку
{ОбщийМодуль.ШтрихКодыСервер.Модуль(439)}: Ошибка при вызове метода контекста (Выполнить)
         Выборка = Запрос.Выполнить().Выбрать();
по причине:
{(9, 36)}: Синтаксическая ошибка "___________%""
И РегШтрихКоды.Штрихкод ПОДОБНО ""<<?>>___________%"
Что за конфигурация?
1С:Библиотека, редакция 2.1 (2.1.7.1) (http://solutions.1c.ru/catalog/library/features)
Copyright (С) ООО "1С", 2016. Все права защищены
(http://www.1c.ru)

alexandr_ll

Цитата: vtaa05 от 05 окт 2018, 09:30
Цитата: alexandr_ll от 05 окт 2018, 09:25
Цитата: vtaa05 от 05 окт 2018, 09:20
Цитата: alexandr_ll от 05 окт 2018, 08:57

Возможно в параметр функции "Тип" передается пустое значение
У меня проблема со штрих-кодами они на читательских билетах не формируются.
Если я задаю вариант формирования штрих-кода "Системная идентификация", то выдает такую ошибку
{ОбщийМодуль.ШтрихКодыСервер.Модуль(439)}: Ошибка при вызове метода контекста (Выполнить)
         Выборка = Запрос.Выполнить().Выбрать();
по причине:
{(9, 36)}: Синтаксическая ошибка "___________%""
И РегШтрихКоды.Штрихкод ПОДОБНО ""<<?>>___________%"
Что за конфигурация?
1С:Библиотека, редакция 2.1 (2.1.7.1) (http://solutions.1c.ru/catalog/library/features)
Copyright (С) ООО "1С", 2016. Все права защищены
(http://www.1c.ru)
С конфигурацией не знаком. В приведенном фрагменте кода видны лишние кавычки.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск