Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
18 апр 2024, 00:41

Поиск в таблице значений

Автор trialex3, 04 окт 2018, 15:08

0 Пользователей и 1 гость просматривают эту тему.

trialex3

Всем привет. Помогите найти причину, почему не ищутся значения в таблице значений.
Есть код:
МассивИзмененныхНомеров = Новый Массив;
ПриводБеллимо = Новый СписокЗначений;
ПриводБеллимо.Добавить("333");
ПриводБеллимо.Добавить("111");
ПриводБеллимо.Добавить("888");
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| АР_ПриводыБеллимо.Привод,
| АР_ПриводыБеллимо.КодИзделия
|ИЗ
| РегистрСведений.АР_ПриводыБеллимо КАК АР_ПриводыБеллимо
|ГДЕ
| АР_ПриводыБеллимо.КодИзделия = &КодИзделия";

Запрос.УстановитьПараметр("КодИзделия", КодИзделияСсылка);

Результат = Запрос.Выполнить();
    ТабЗнач = Результат.Выгрузить();

Для каждого Элемент Из ПриводБеллимо Цикл
// Если ТабЗнач.Найти(Элемент,"Привод") = Неопределено Тогда
// МассивИзмененныхНомеров.Добавить(Элемент);
//КонецЕсли;
Отбор = Новый Структура();
Отбор.Вставить("Привод",Элемент);
Строки = ТабЗнач.НайтиСтроки(Отбор);

Если Строки.Количество() = 0 Тогда
МассивИзмененныхНомеров.Добавить(Элемент);
КонецЕсли;
КонецЦикла;

По идее Значения из СпискаЗначений ПриводБеллимо должны соотнестить с результатом запроса и несовпадающие значения записаться в массив, но поиск говорит что ни одно из значений в ТабЗнач не найдено.
Вот результат запроса: Ссылка
Текстовые значения как и в списке значений. По идее в МассивИзмененныхНомеров должно быть только значение "888", а там все значения. Что не так?

trialex3

вопрос решен. СписокЗначений и ТаблицаЗначений конфликтовали чет. Сделал вместо списка таблицу и норм
Добавлено: 04 окт 2018, 17:42


Точнее делов не в списке а вот что я искал в таблице не текст из списка значений а элемент списка значений. Т е вместо элемент надо было писать элемент.значение

Теги:  

Похожие темы (5)

Рейтинг@Mail.ru

Поиск