Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 апр 2024, 00:16

Проверка кода на наличие ошибок

Автор Вадим Ф2, 26 сен 2018, 10:44

0 Пользователей и 1 гость просматривают эту тему.

Вадим Ф2

Добрый день!
Написал код, очень важно знать нет ли в нем ошибок.
Если кому не тяжело, гляньте пожалуйста, все ли правильно.

Заранее спасибо!


Процедура КнопкаВыполнитьНажатие(Кнопка)

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ИсходящееПлатежноеПоручение.Ссылка,
| ИсходящееПлатежноеПоручение.Дата,
| ИсходящееПлатежноеПоручение.ВидОперации
|ИЗ
| Документ.ПлатежноеПоручениеИсходящее КАК ИсходящееПлатежноеПоручение
|ГДЕ
| ИсходящееПлатежноеПоручение.Проведен = ИСТИНА
| И ИсходящееПлатежноеПоручение.ВидОперации = &ВидОперации
| И ИсходящееПлатежноеПоручение.Дата МЕЖДУ &ДатаНачала И &ДатаОкончания";

Запрос.УстановитьПараметр("ВидОперации", Перечисления.ВидыОперацийППИсходящее.ОплатаПоставщику);
Запрос.УстановитьПараметр("ДатаНачала", ДатаНачала);
Запрос.УстановитьПараметр("ДатаОкончания", ДатаОкончания);

Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл

ДокОбъект = Выборка.Ссылка.ПолучитьОбъект();
ДокОбъект.Комментарий = ДокОбъект.СчетОрганизации;
ДокОбъект.СчетОрганизации = РасчетныйСчет;
ДокОбъект.Записать();

КонецЦикла;



КонецПроцедуры


Код находится в модуле формы, на которой есть выбор даты начала, даты конца и выбор счета.

alexandr_ll

Цитата: Вадим Ф2 от 26 сен 2018, 10:44
Добрый день!
Написал код, очень важно знать нет ли в нем ошибок.
Если кому не тяжело, гляньте пожалуйста, все ли правильно.

Заранее спасибо!


Процедура КнопкаВыполнитьНажатие(Кнопка)

Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ИсходящееПлатежноеПоручение.Ссылка,
| ИсходящееПлатежноеПоручение.Дата,
| ИсходящееПлатежноеПоручение.ВидОперации
|ИЗ
| Документ.ПлатежноеПоручениеИсходящее КАК ИсходящееПлатежноеПоручение
|ГДЕ
| ИсходящееПлатежноеПоручение.Проведен = ИСТИНА
| И ИсходящееПлатежноеПоручение.ВидОперации = &ВидОперации
| И ИсходящееПлатежноеПоручение.Дата МЕЖДУ &ДатаНачала И &ДатаОкончания";

Запрос.УстановитьПараметр("ВидОперации", Перечисления.ВидыОперацийППИсходящее.ОплатаПоставщику);


Выборка = Запрос.Выполнить().Выбрать();

Пока Выборка.Следующий() Цикл

ДокОбъект = Выборка.Ссылка.ПолучитьОбъект();
ДокОбъект.Комментарий = ДокОбъект.СчетОрганизации;
ДокОбъект.СчетОрганизации = РасчетныйСчет;
ДокОбъект.Записать();

КонецЦикла;



КонецПроцедуры


Код находится в модуле формы, на которой есть выбор даты начала, даты конца и выбор счета.
Приложение обычное или управляемое?
Даты в запросе следует уточнить

Запрос.УстановитьПараметр("ДатаНачала", НачалоДня(ДатаНачала));
Запрос.УстановитьПараметр("ДатаОкончания", КонецДня(ДатаОкончания));

Вадим Ф2

Приложение обычное.

Понял. Спасибо!

Теги: ошибка код 

Похожие темы (5)

Рейтинг@Mail.ru

Поиск