Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
18 апр 2024, 01:24

Ошибка чтения значения в запросе

Автор Зофа, 04 сен 2018, 09:33

0 Пользователей и 1 гость просматривают эту тему.

Зофа

Приветсвую коллеги. Столкнулся с ошибкой чтения значения в запросе. В Консоле запросов, выводит правильные данные. Может кто ткнёт где косяк(


Запрос = Новый Запрос;
Запрос.Текст =
     "ВЫБРАТЬ
     | ОстДетальный.Сумма
     |ИЗ
     | РегистрНакопления.ОстДетальный КАК ОстДетальный
     |ГДЕ
     | ОстДетальный.СтатьяЗатрат = &СтатьяЗатрат
     | И ОстДетальный.Активност = &Активност
     | И ОстДетальный.Признание = &Признание";

        Запрос.УстановитьПараметр("Активност", Стр.НомерАктивности);
Запрос.УстановитьПараметр("СтатьяЗатрат", Стр.СтатьяЗатрат);
Запрос.УстановитьПараметр("Признание", Истина);

  РезультатЗапроса = Запрос.Выполнить();
        ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
        Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            Стр.СуммаУтвержд = РезультатЗапроса.Сумма;
        КонецЦикла;




MuI_I_Ika

А подробней какую ошибку выводит?

Зофа

Цитата: MuI_I_Ika от 04 сен 2018, 10:08
А подробней какую ошибку выводит?
В отладке ошибку не выводит, просто не передаёт цифры из регистра, а в конфигураторе когда пытаюсь вычислить выражение выдаёт ошибку чтения значения.

MuI_I_Ika

Вот так правильно:

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            Стр.СуммаУтвержд = ВыборкаДетальныеЗаписи.Сумма;
        КонецЦикла;

Зофа

Цитата: MuI_I_Ika от 04 сен 2018, 10:15
Вот так правильно:

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            Стр.СуммаУтвержд = ВыборкаДетальныеЗаписи.Сумма;
        КонецЦикла;

Спасибо, но эффект тот же. Если я правильно понял, вычислять нужно выражение ВыборкаДетальныеЗаписи, но в нём при вычислении ругается на то, что Свойство- Сумма,  Значение - Ошибка чтения значения.

MuI_I_Ika

А записи то в регистре есть?

Зофа

Цитата: MuI_I_Ika от 04 сен 2018, 10:22
А записи то в регистре есть?
Да конечно. Фактически в запросе используются почти все реквизиты регистра.

MuI_I_Ika

А точка останова стоит на вот этой строке в момент проверки?

Стр.СуммаУтвержд = ВыборкаДетальныеЗаписи.Сумма;

Зофа

Цитата: MuI_I_Ika от 04 сен 2018, 10:28
А точка останова стоит на вот этой строке в момент проверки?

Стр.СуммаУтвержд = ВыборкаДетальныеЗаписи.Сумма;
Нет на
Запрос.УстановитьПараметр("Активност", Стр.НомерАктивности);

MuI_I_Ika

Ну так хотябы программа в момент вычисления значения находится на этой строке?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск