Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
18 апр 2024, 00:18

Вопрос по выгрузке макета тип("ДвоичныеДанные") ВПФ в файл

Автор Albert123, 03 сен 2018, 10:14

0 Пользователей и 1 гость просматривают эту тему.

Albert123

Есть задача нужно настроить программно кнопку на форме внешней пеатнй формы ,чтоб макет выгружался в файл .Не понимаю как работать с двоичными данными с сервера на клиент .Вот мой код .

&НаСервере
Функция ПолучитьМакетОбработки()
ВнешОбработка="C:\Users\MalinkinAE\Desktop\ВнешняяОбработка111";
МакетОбработки = ВнешОбработка.ПолучитьМакет("Макет1");
МакетОбработки.ПоместитьВоВременноеХранилище("МакетОбработки","C:\Users\MalinkinAE\Desktop\1111");
Возврат МакетОбработки
КонецФункции

&НаКлиенте
Процедура Записать(Команда)
МакетОбработки=ПолучитьМакетОбработки();
МакетОбработки.ПолучитьИзВременногоХранилища("C:\Users\MalinkinAE\Desktop\1111");
МакетОбработки.Записать ("C:\Users\MalinkinAE\Desktop\55555");
КонецПроцедуры

Albert123

Проблема решена написал вот такой код,мало ли кому понадобится:


&НаСервере
Функция ПолучитьФайл()
Двоичное=Новый ДвоичныеДанные("C:\Users\MalinkinAE\Desktop\ВнешняяОбработка111.epf");
Двоичное= РеквизитФормыВЗначение("Объект");
Макет= Двоичное.ПолучитьМакет("Макет1");
Адрес=ПоместитьВоВременноеХранилище(Макет,ЭтаФорма.УникальныйИдентификатор);
Возврат Адрес
КонецФункции

&НаКлиенте
Процедура Записать(Команда)
Адрес=ПолучитьФайл();
Макет=ПолучитьФайл();
Макет=ПолучитьИзВременногоХранилища(Адрес);
Макет.Записать ("C:\Users\MalinkinAE\Desktop\1111\333");
КонецПроцедуры   

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск