Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 апр 2024, 00:37

Пересчет Суммы при изменении Цены или Количества. Как сделать?

Автор nagibetor, 30 авг 2018, 21:41

0 Пользователей и 1 гость просматривают эту тему.

nagibetor

Процедура ОбработкаПроведения(Отказ, Режим)
   //{{__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
   // Данный фрагмент построен конструктором.
   // При повторном использовании конструктора, внесенные вручную изменения будут утеряны!!!

   // регистр Взаиморасчет Расход
   Движения.Взаиморасчет.Записывать = Истина;
   Движение = Движения.Взаиморасчет.Добавить();
   Движение.ВидДвижения = ВидДвиженияНакопления.Расход;
   Движение.Период = Дата;
   Движение.Контрагент = Контрагент;
   Движение.Сумма = СуммаДокумента;
   
   Движения.ТоварНаСкладах.Записывать = Истина;

      Для Каждого ТекСтрокаТовары Из Товары Цикл
      // регистр ТоварНаСкладах Приход

      Движение = Движения.ТоварНаСкладах.Добавить();
      Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
      Движение.Период = Дата;
      Движение.Номенклатура = ТекСтрокаТовары.Товар;
      Движение.Склад = Склад;
      Движение.Количество = ТекСтрокаТовары.Количество;
      
      КонецЦикла;


   //}}__КОНСТРУКТОР_ДВИЖЕНИЙ_РЕГИСТРОВ
КонецПроцедуры

Каримдат


&НаКлиенте
Процедура ТоварыЦенаПриИзменении(Элемент)
РассчитатьСуммуТабличнойЧастиТовары();
КонецПроцедуры

&НаКлиенте
Процедура ТоварыКоличествоПриИзменении(Элемент)
РассчитатьСуммуТабличнойЧастиТовары();
КонецПроцедуры

&НаКлиенте
Процедура РассчитатьСуммуТабличнойЧастиТовары()
ТекущиеДанные = Элементы.Товары.ТекущиеДанные;
ТекущиеДанные.Сумма = ТекущиеДанные.Цена*ТекущиеДанные.Количество;
КонецПроцедуры

nagibetor

Цитата: Каримдат от 30 авг 2018, 21:50

&НаКлиенте
Процедура ТоварыЦенаПриИзменении(Элемент)
РассчитатьСуммуТабличнойЧастиТовары();
КонецПроцедуры

&НаКлиенте
Процедура ТоварыКоличествоПриИзменении(Элемент)
РассчитатьСуммуТабличнойЧастиТовары();
КонецПроцедуры

&НаКлиенте
Процедура РассчитатьСуммуТабличнойЧастиТовары()
ТекущиеДанные = Элементы.Товары.ТекущиеДанные;
ТекущиеДанные.Сумма = ТекущиеДанные.Цена*ТекущиеДанные.Количество;
КонецПроцедуры

Добавлено: 30 авг 2018, 21:58


Цитата: nagibetor от 30 авг 2018, 21:56
Цитата: Каримдат от 30 авг 2018, 21:50

&НаКлиенте
Процедура ТоварыЦенаПриИзменении(Элемент)
РассчитатьСуммуТабличнойЧастиТовары();
КонецПроцедуры

&НаКлиенте
Процедура ТоварыКоличествоПриИзменении(Элемент)
РассчитатьСуммуТабличнойЧастиТовары();
КонецПроцедуры

&НаКлиенте
Процедура РассчитатьСуммуТабличнойЧастиТовары()
ТекущиеДанные = Элементы.Товары.ТекущиеДанные;
ТекущиеДанные.Сумма = ТекущиеДанные.Цена*ТекущиеДанные.Количество;
КонецПроцедуры


Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск