Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 апр 2024, 01:45

Программное заполнение реквизитов документа

Автор Кот_Леопольд, 20 авг 2018, 09:35

0 Пользователей и 1 гость просматривают эту тему.

Кот_Леопольд

Добрый День.
Имеем Документ.Заказ, в нем есть реквизиты:
СрокИзготовленияЗаказа  тип Число; (заполняется автоматически в свойствах реквизита "значение заполнения = 3")
ДатаСдачиЗаказа тип Дата.
Хочу что бы реквизит ДатаСдачиЗаказа заполнялся автоматически при создании документа
Примерно это вижу так:
ДатаСдачиЗаказа = ДобавитьДень(ТекущаяДата(), СрокИзготовленияЗаказа);
Но проблема в том что не знаю где писать программный код и как его правильно оформить.
P.S: Отнесись с пониманием, я только учусь!!! Спасибо!!!

alexandr_ll

Цитата: Кот_Леопольд от 20 авг 2018, 09:35
Добрый День.
Имеем Документ.Заказ, в нем есть реквизиты:
СрокИзготовленияЗаказа  тип Число; (заполняется автоматически в свойствах реквизита "значение заполнения = 3")
ДатаСдачиЗаказа тип Дата.
Хочу что бы реквизит ДатаСдачиЗаказа заполнялся автоматически при создании документа
Примерно это вижу так:
ДатаСдачиЗаказа = ДобавитьДень(ТекущаяДата(), СрокИзготовленияЗаказа);
Но проблема в том что не знаю где писать программный код и как его правильно оформить.
P.S: Отнесись с пониманием, я только учусь!!! Спасибо!!!
Какая конфигурация?
Или хотя бы приложение - обычное или управляемое?

Кот_Леопольд

Какая конфигурация?
Или хотя бы приложение - обычное или управляемое?

Конфигурация 1С: Предприятие 8.3

Sy4a

В свойствах формы есть событие "ПриСозданииНаСервере". И прежде чем заполнять проверьте поле на заполненность а то будет перезаполняться каждый раз перед открытием документа.
Если не ЗначениеЗаполнено(ДатаСдачиЗаказа) тогда
ДатаСдачиЗаказа = ДобавитьДень(ТекущаяДата(), СрокИзготовленияЗаказа);
КонецЕсли;

Кот_Леопольд

Цитата: Sy4a от 20 авг 2018, 16:08
В свойствах формы есть событие "ПриСозданииНаСервере". И прежде чем заполнять проверьте поле на заполненность а то будет перезаполняться каждый раз перед открытием документа.
Если не ЗначениеЗаполнено(ДатаСдачиЗаказа) тогда
ДатаСдачиЗаказа = ДобавитьДень(ТекущаяДата(), СрокИзготовленияЗаказа);
КонецЕсли;

Ругается!?


alex0402

Цитата: Кот_Леопольд от 21 авг 2018, 08:18Ругается!?

и правильно делает! есть только ДобавитьМесяц. нет такой функции, но ее можно написать. например:

Функция ДобавитьДень(Дата,Кво)

    Возврат Дата + Кво*86400;

КонецФункции


если функция нужна один раз, то ее лучше вставить в код.
Спасибо за Сказать спасибо

Кот_Леопольд

и правильно делает! есть только ДобавитьМесяц. нет такой функции, но ее можно написать. например:

Функция ДобавитьДень(Дата,Кво)

    Возврат Дата + Кво*86400;

КонецФункции


если функция нужна один раз, то ее лучше вставить в код.
[/quote]

Огромное СПАСИБО!!! Все работает!!!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск