Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
21 апр 2024, 14:19

Расчет суммы

Автор Тапок, 14 авг 2018, 07:52

0 Пользователей и 1 гость просматривают эту тему.

Тапок

Люди добрые, подскажите, не заполняется автоматически сумма, при добавление услуги. Цена забивается автоматически , количество ввожу в ручную , сумма не производит расчет , дает пустую ячейку, без ошибок и прочих предупреждений.
События выбирал "ПриИзменении", как и для количества, так и для суммы.
Может что в коде не так? Пробовал по разному.
Элементы.ДобУслуг.ТекущиеДанные.Сумма = Элементы.ДобУслуг.ТекущиеДанные.Цена* Элементы.ДобУслуг.ТекущиеДанные.Количество;
И по другому пробовал.
ТабЧаст= Элементы.ДобУслуг.ТекущиеДанные;
ТабЧаст.Сумма = ТабЧаст.Цена*ТабЧаст.Количество; 
На клиенте.


wise

(0) "Объект" попробуй ВМЕСТО "Элементы"
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Alex26

Цитата: Тапок от 14 авг 2018, 07:52
ТабЧаст= Элементы.ДобУслуг.ТекущиеДанные;
ТабЧаст.Сумма = ТабЧаст.Цена*ТабЧаст.Количество; 
На клиенте.

Попробуй так

Для каждого строкаТЧ Из Объект.ДобУслуг Цикл
    строкаТЧ.Сумма = строкаТЧ.Количество * строкаТЧ.Цена;
КонецЦикла;

Тапок

Нет, не считается сумма. Может потому, что цена автоматически ставится , при выборе услуги ? Уже все события перепробовал и никак.
Добавлено: 15 авг 2018, 07:52


Еще на эту форму условие стоит.


&НаКлиенте
Процедура ПриОткрытии(Отказ)
     УстановитьВидимость ();

КонецПроцедуры

Процедура УстановитьВидимость ()
   
   Если Объект.Стоимость = Истина
      Тогда
       Элементы.ДобУслугЦена.Видимость = Ложь ;
       Элементы.ДобУслугЦенаВтр.Видимость = Истина   ;
   Иначе
       Элементы.ДобУслугЦена.Видимость = Истина   ;
       Элементы.ДобУслугЦенаВтр.Видимость = Ложь ;
   КонецЕсли;
            
   
КонецПроцедуры

&НаКлиенте
Процедура СтоимостьПриИзменении(Элемент)
УстановитьВидимость ();
КонецПроцедуры

Добавлено: 15 авг 2018, 07:54


Цитата: wise от 14 авг 2018, 16:31
(0) "Объект" попробуй ВМЕСТО "Элементы"

Пробовал ставить Объект . Выдает ошибку, Объект - количество , нельзя приравнять к числу. Хотя тип число стоит, точность 2, неотрицательное.

Alex26

Цитата: Тапок от 15 авг 2018, 07:49&НаКлиенте
Процедура СтоимостьПриИзменении(Элемент)
УстановитьВидимость ();
КонецПроцедуры
Вот так, тебе тогда надо

&НаКлиенте
Процедура СтоимостьПриИзменении(Элемент)
УстановитьВидимость ();

Если Элементы.ДобУслугЦена.Видимость = Ложь Тогда

Для каждого строкаТЧ Из Объект.ДобУслуг Цикл

строкаТЧ.Сумма = строкаТЧ.Количество * строкаТЧ.ЦенаВтр;

КонецЦикла;

Иначе

Для каждого строкаТЧ Из Объект.ДобУслуг Цикл

строкаТЧ.Сумма = строкаТЧ.Количество * строкаТЧ.Цена;

КонецЦикла;

КонецЕсли;
КонецПроцедуры

AIFrame

И в документе с 1000+ строк работа с ним превратится в АдЪ.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск