Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 июл 2024, 06:04

Получить данные из справочника

Автор Ruslan09609, 25 июл 2018, 09:08

0 Пользователей и 1 гость просматривают эту тему.

Ruslan09609

Добрый день,подскажите пожалуйста как получить данные из справочника.
Мне нужно получить ЦенуПокупки из справочника Справочники.Номенклатура там в табличной части(Таблица) сидят эти данные. Посмотрите что я не так написал в коде,выдает ошибку ({Документ.ПоступлениеТовара.Форма.ФормаДокумента.Форма(9)}: Поле объекта не обнаружено (Таблица)
Возврат Справочники.Номенклатура.Таблица.ЦенаПокупки;)


&НаКлиенте
Процедура ТаблицаНоменклатураПриИзменении(Элемент)
спр = элементы.Таблица.ТекущиеДанные;
спр.Цена = ПолучитьЦену (Спр.Номенклатура);
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьЦену(Номенклатура)
Возврат Справочники.Номенклатура.Таблица.ЦенаПокупки;
КонецФункции




wise

(0) если Таблица ЭТО табличная часть справочника, то "ЦенаПокупки" покупки ДОЛЖНА браться из КАКОЙ-ТО строки ЭТОЙ табличной части.

например: Справочники.Номенклатура.Таблица[0].ЦенаПокупки
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Ruslan09609

Цитата: wise от 25 июл 2018, 09:20
(0) если Таблица ЭТО табличная часть справочника, то "ЦенаПокупки" покупки ДОЛЖНА браться из КАКОЙ-ТО строки ЭТОЙ табличной части.

например: Справочники.Номенклатура.Таблица[0].ЦенаПокупки

Посмотрите пожалуйста скрин,вроде указал что строка 1 но ошибка ({Документ.ПоступлениеТовара.Форма.ФормаДокумента.Форма(9)}: Поле объекта не обнаружено (Таблица)
Возврат Справочники.Номенклатура.Таблица[1].ЦенаПокупки;)
Добавлено: 25 июл 2018, 09:41


Путь данным на скриншоте

Sy4a


&НаСервереБезКонтекста
Функция ПолучитьЦену(Номенклатура)
Возврат Номенклатура.Таблица[0].ЦенаПокупки;
КонецФункции

wise

(2) Возврат Номенклатура.Таблица[0].ЦенаПокупки;

слово "Справочники" НЕ нужно, в квадратных скобках указывается ИНДЕКС(начинается с нуля)

если ТЧ не обязательная к заполнению, то в случае пустой ТЧ будет ОШИБКА...
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск