Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
18 апр 2024, 00:39

Универсальные коллекции значений

Автор Александр2018, 24 июл 2018, 05:27

0 Пользователей и 1 гость просматривают эту тему.

Александр2018

Привет! Можно ли в массив из 2х элементов записать структуру и таблицу значений? Т.е. в одном элементе массива будет структура, а во втором таблица. B) Или подскажите, где можно наглядно посмотреть про все типы коллекции значений и что в них можно записать, такие как массив структура, таблица значений и т. д.

LexaK

да можно (правда смотря где) а почитать можно и нужно в синтаксис-помощнике (в конфигураторе нажмите кнопки ctrl+shift+F1)
да и любые книжки по 1С ни кто не отменял :befhbt:
если помогло нажмите: Спасибо!

Sy4a


Массив=новый массив();
Структура=Новый структура();
ТЗ=Новый ТаблицаЗначений;
Массив.Добавить(Структура);
Массив.Добавить(ТЗ);

//обход массива
Для каждого элемент из массив цикл
Если ТипЗнч(элемент)=Тип("Структура")тогда
Для каждого ЭлементСтруктуры из Элемент цикл
//обходим структуру
КонецЦикла;
ИначеЕсли ТипЗнч(элемент)=Тип("ТаблицаЗначений")тогда
Для каждого СтрТЗ из Элемент цикл
//обходим ТЗ
КонецЦикла;
КонецЦикла;

Как то так наверно, но не проверял :)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск