Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 апр 2024, 11:00

Обновление Розница 2.2.6

Автор Константин Чернышев, 21 июл 2018, 14:40

0 Пользователей и 1 гость просматривают эту тему.

Константин Чернышев

При установке онлайн-кассы спецы обновили товарищу Розница 2.0.4.5 до 2.2.6.33. После этого при запуске 1С выскакивает сообщение о незавершенности процесса обновления (https://yadi.sk/i/56aItAkQ3ZRBrR). Спецы утверждают, что "все ОК, просто закрывайте это окошко и работайте спокойно!". Однако, дальнейшие обновления не устанавливаются... Нажатие на кнопочку "Выполнить процедуры обработки данных" приводит к сообщению (https://yadi.sk/i/c882qVZ93ZRC8z) о выполнении 10 процедур из 17. Следующие обновления по-прежнему не ставятся. Нажатие на ссылку "...(10 из 17)" вываливает таблицу с перечнем процедур и результатами их выполнения (10 "вып", 2 "ошибка" и 5 "не выполнялось") (https://yadi.sk/i/b0eiSIxA3ZRCXJ).
Вопрос: что это за беда и как с ней бороться?

AIFrame

Розница базовая или Проф?
Нужен отчет о сравнении конфигурации с конфигурацией поставщика.
Текущая минимально-актуальная версия Розницы - 2.2.7.42, рекомендуемая 2.2.8.29. Последняя - 2.2.9.19, но ее можно юзать только в 8.3.10.
ЦитироватьПри подписке ЗаполнитьНаборыЗначенийДоступаТабличныхЧастейСправочников на событие ПередЗаписью произошла ошибка. Метод обработчика события ЗаполнитьНаборыЗначенийДоступаТабличныхЧастей не найден.
Криво перенесли или у общего модуля УправлениеДоступом не выставлены нужные флаги вызова (Сервер, Внешнее)
// Обработчик подписок ЗаполнитьНаборыЗначенийДоступаТабличныхЧастей* на событие ПередЗаписью
// вызывает заполнение значений доступа табличной части объекта НаборыЗначенийДоступа,
// когда для ограничения доступа к самому объекту используется шаблон #ПоНаборамЗначений.
//  Возможен случай использования подсистемы Управление доступом, когда
// указанной подписки не существует, если для указанной цели наборы не применяются.
//
// Параметры:
//  Источник        - СправочникОбъект,
//                    ДокументОбъект,
//                    ПланВидовХарактеристикОбъект,
//                    ПланСчетовОбъект,
//                    ПланВидовРасчетаОбъект,
//                    БизнесПроцессОбъект,
//                    ЗадачаОбъект,
//                    ПланОбменаОбъект - объект данных, передаваемый в подписку на событие ПередЗаписью.
//
//  Отказ           - Булево - параметр, передаваемый в подписку на событие ПередЗаписью.
//
//  РежимЗаписи     - Булево - параметр, передаваемый в подписку на событие ПередЗаписью,
//                    когда тип параметра Источник - ДокументОбъект.
//
//  РежимПроведения - Булево - параметр, передаваемый в подписку на событие ПередЗаписью,
//                    когда тип параметра Источник - ДокументОбъект.
//
Процедура ЗаполнитьНаборыЗначенийДоступаТабличныхЧастей(Источник, Отказ = Неопределено, РежимЗаписи = Неопределено, РежимПроведения = Неопределено) Экспорт

Если Источник.ОбменДанными.Загрузка
   И НЕ Источник.ДополнительныеСвойства.Свойство("ЗаписатьНаборыЗначенийДоступа") Тогда

Возврат;
КонецЕсли;

Если СтандартныеПодсистемыСервер.ЭтоИдентификаторОбъектаМетаданных(Источник) Тогда
Возврат;
КонецЕсли;

Если НЕ (  ПривилегированныйРежим()
         И Источник.ДополнительныеСвойства.Свойство(
             "НаборыЗначенийДоступаТабличнойЧастиЗаполнены")) Тогда

Таблица = УправлениеДоступомСлужебный.ПолучитьНаборыЗначенийДоступаТабличнойЧасти(Источник);
УправлениеДоступомСлужебный.ПодготовитьНаборыЗначенийДоступаКЗаписи(Неопределено, Таблица, Ложь);
Источник.НаборыЗначенийДоступа.Загрузить(Таблица);
КонецЕсли;

КонецПроцедуры


Константин Чернышев

Версия программы: https://yadi.sk/i/o8qHDHit3ZSRN3
Цитата: AIFrame от 22 июл 2018, 01:38Криво перенесли или у общего модуля УправлениеДоступом не выставлены нужные флаги вызова (Сервер, Внешнее)
Про перенос (2.0.4.5 до 2.2.6.33) не скажу, делалось месяца 1.5-2 назад без меня. Флаги стоят: https://yadi.sk/i/xPw0cbff3ZSQ6L
Доп информация: В Журнале перед записями об обновлении и ошибках идет 180 записей типа
"Данные. Изменение   Отчет о розничных продажах 0000-000047 от 05.04.2013 18:59:47   Документ. Отчет о розничных продажах"
Каких-либо ошибок в проведении/движениях/оформлении этих доков обнаружить пока не удалось. Доки обрабатываются НЕ в хронологическом порядке(??).



AIFrame

Цитировать8.3.12
Режим совместимости у конфы какой?

Константин Чернышев

Режим совместимости: Версия 8.3.10
Добавлено: 23 июл 2018, 08:34


Попробовал режимы совместимости "8.3.11" и "не использовать". Результат тот же...:angry::dfbsdfbsdf:

Константин Чернышев

Сумел все-таки завершить все процедуры обновления! (https://yadi.sk/i/B7wDpMqQ3Zgixc)
Однако дальнейшие обновления так и не проходят... (https://yadi.sk/i/ah0v7x7n3Zgiz7)
Нашел чистую базу 2.2.6.33. Выгружаю из своей (обновленной "спецами" от 2.0.4.5 до 2.6.33) данные и пытаюсь загрузить их в "чистую"...
Облом!!! "Неверный формат файла выгрузки"! (https://yadi.sk/i/cGA0qWRE3ZgiMn) Как такое может быть? Одна и та же обработка (ВыгрузкаЗагрузкаДанныхXML83.epf с ИТС "Конвертация данных 2.1.8.2") работает и при выгрузке, и при загрузке!!!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск