Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 июн 2024, 14:23

Вывод на печать по циклу

Автор АлексейП, 07 июл 2018, 15:55

0 Пользователей и 1 гость просматривают эту тему.

АлексейП

В силу своей неопытности. вынужден обратиться к вам. Задача программы такая. Я ввожу диапазон чисел (нижний предел и верхний), выбираю знак: +, -, / или * , выбираю сколько раз примеров, должно вывести на печатную форму. То есть по диапазону формируется случайное число: число1 и число2, далее формируется пример (в зависимости от выбранного знака) например: число1 + число2 = и в зависимости от числа примеров выводится скажем 42 примера со знаком "+" но с разными числами. Решил забодяжить программку для ребенка. Учится решать примеры в 5 лет. Решает по 40 примеров со знаком "+" и 40 со знаком "-". Но постоянно писать в тетрадке муторно, да и выдумывать примеры в голове фантазия иссякает=)). Пускай думает программа и выводит это все на печать. Алгоритм проверял, выводит в сообщении прекрасно примеры, а с печатными формами я не сталкивался еще. Ну и есть повод усвоить еще одну тему для себя. Помогите решить задачу. Вообщем не выводит примеры с разными цифрами. Все в скрине. Случайное число помещаю в переменную СлучЧисло. До этого пробовал в цикле ПОКА...
&НаКлиенте
Процедура Печать(Команда)
ТабДок=Новый ТабличныйДокумент;
    СформироватьОтчет(ТабДок);
    ТабДок.ОтображатьСетку = Ложь;
    ТабДок.ОтображатьЗаголовки = Ложь;
    ТабДок.ТолькоПросмотр =Истина;
    ТабДок.Показать("СформироватьЗадачу");
//ТабДок.Напечатать();




//Для Счетчик =1  По Объект.ЧислоПримеров  Цикл

//Сообщить(СлучайноеЧисло()+Объект.Знак+СлучайноеЧисло());
//

//КонецЦикла;

КонецПроцедуры

&НаСервере
Процедура СформироватьОтчет(ТабДок)

Макет =  Обработки.СформироватьЗадачу.ПолучитьМакет("СформироватьПримеры"); 
  ОбластьШапка = Макет.ПолучитьОбласть("Шапка");
    ОбластьДанные = Макет.ПолучитьОбласть("Данные");
        ТабДок.Вывести(ОбластьШапка);
            ОбластьДанные.Параметры.Знак = Объект.Знак;

Для Счетчик =1  По Объект.ЧислоПримеров  Цикл

СлучЧисло = СлучайноеЧисло();
    ОбластьДанные.Параметры.СлучЧисло =  СлучЧисло; 
                 ТабДок.Вывести(ОбластьДанные); 
  КонецЦикла;

       КонецПроцедуры           

Функция СлучайноеЧисло()
Число1 = Объект.Число;
Число2=  Объект.до;
ГСЧ = Новый ГенераторСлучайныхЧисел();
    СлучайноеЧисло = ГСЧ.СлучайноеЧисло(Число1, Число2);
Возврат     Строка(СлучайноеЧисло);
КонецФункции


Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск