Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 апр 2024, 10:52

Помогите новичку =)

Автор TotTIM, 27 июн 2018, 11:28

0 Пользователей и 1 гость просматривают эту тему.

TotTIM

Тону дали задачу, что то тыркаюсь и не выходит)
Я новичёк, работаю в этой сфере  недавно... и много чего не знаю-путаюсь.
В инете ненашёл этот момент... 
8.2 Полиграфия.

В документе "СложныйЗаказ" есть окно "СтатусЗаказа" с кнопкой выбора (из справочника).
В этом списке в разных документах нам нужно находить "Утвержден менеджером"
Т.е.
Если в документе "СложныйЗаказ"  в "СтатусЗаказа" стоит "Утвержден менеджером" 
Тогда нужно Убрать доступ к редактированию документа. ( можно просмотр сделать ).
И от греха подальше если вдруг этоненадёжно то и право Записи в этом документе.

В моём коде там уже много лишнего написано, я уже начал всё подрят пробывать...
Я массив задействовал походу...
Подскажите :(
Мне надо заблокировать доступ менеджерам редактирование документов после того как они поставят статус Утверджён менеджером.

(часть кода)
Процедура ПриОткрытии()

   СписокВыбораЗнач=Этаформа.ЭлементыФормы.Получить(СтатусЗаказа);
// это неверно... мне надо получить значение окна СтатусЗаказа.
      Если
      РольДоступна("ПользовательНаш1")=Истина
      Тогда      
      Если
       СписокВыбораЗнач="Утверджен менеджером"
      Тогда
      ЭтаФорма.ЭлементыФормы.СтатусЗаказа.ТолькоПросмотр = Истина;      
      
      КонецЕсли;
     КонецЕсли;
КонецПроцедуры;

wise

(0) Объект.СтатусЗаказа
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

TotTIM

Цитата: wise от 27 июн 2018, 12:07
(0) Объект.СтатусЗаказа

Цитировать{Документ.П_СложныйЗаказ.Форма.ФормаДокумента.Форма(713,15)}: Процедура или функция с указанным именем не определена (Объект)
        Сыллка2=<<?>>Объект(Этаформа.ЭлементыФормы.СтатусЗаказа); (Проверка: Толстый клиент (обычное приложение))

Цитировать{Документ.П_СложныйЗаказ.Форма.ФормаДокумента.Форма(713,15)}: Переменная не определена (Объект)
        Сыллка2=<<?>>Объект.СтатусЗаказа; (Проверка: Толстый клиент (обычное приложение))
Что то не работает.
Можно более открыто с примером какимнить. Я и так и сяк и путь прописывал... или сыллку где это показывают.
Или хотите сказать что это запросом? 

wise

если ЭТО обычные формы... ТОГДА просто:
//ищешь свой статус
СтатусУтвержден = Справочники.СтатусыЗаказов.НайтиПоНаименованию("Утвержден менеджером");//или по коду ЛУЧШЕ ищи(если ЭТО, вообще, НЕ перечисление)
Если СтатусЗаказа=СтатусУтвержден Тогда
    ЭтаФорма.ТолькоПросмотр = Истина;
КонецЕсли;


p.s. примерно ТАК...
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

TotTIM

Цитата: wise от 27 июн 2018, 15:37
если ЭТО обычные формы... ТОГДА просто:
//ищешь свой статус
СтатусУтвержден = Справочники.СтатусыЗаказов.НайтиПоНаименованию("Утвержден менеджером");//или по коду ЛУЧШЕ ищи(если ЭТО, вообще, НЕ перечисление)
Если СтатусЗаказа=СтатусУтвержден Тогда
    ЭтаФорма.ТолькоПросмотр = Истина;
КонецЕсли;


p.s. примерно ТАК...

Я понял спасибо,  вроде получилось.

Аекс

Добрый день форумчане!)
подскажите вот не вижу колличество материала у меня на складах ,
захожу в номенклатуру любой товар выбираю, например "лопата" не показывает сколько  у меня и у кого сколько ,что может быть

ВЕРСИЯ 1С ПРЕДПРИЯТИЕ УПРАВЛЕНИЕ ТОРГОВЛЕЙ РЕДАКЦИЯ 10.3

alexandr_ll

Цитата: Аекс от 04 июл 2018, 14:12
Добрый день форумчане!)
подскажите вот не вижу колличество материала у меня на складах ,
захожу в номенклатуру любой товар выбираю, например "лопата" не показывает сколько  у меня и у кого сколько ,что может быть

ВЕРСИЯ 1С ПРЕДПРИЯТИЕ УПРАВЛЕНИЕ ТОРГОВЛЕЙ РЕДАКЦИЯ 10.3
Откройте форму подбора из любого документа, например Счет покупателя.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск