Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 апр 2024, 11:50

Как изменить значение перечисления из общего модуля?

Автор Tsunami Flow, 20 июн 2018, 06:58

0 Пользователей и 1 гость просматривают эту тему.

Tsunami Flow

Добрыйдень!
В общем модуле выполняю код
ЦитироватьЕсли СтатусИнформационнойБазы=ПредопределенноеЗначение("Перечисление.Тех_СтатусИнформационнойБазы.Актуальная")
      Тогда      СтатусИнформационнойБазы=ПредопределенноеЗначение("Перечисление.Тех_СтатусИнформационнойБазы.ОтправленЗапросПользователю");
      СтатусИнформационнойБазы.Записать();   
   КонецЕсли

Выдает ошибку "Поле объекта недоступно для записи (СтатусИнформационнойБазы)"
Прошу помощи в решении этой ситуации

alexandr_ll

Цитата: Tsunami Flow от 20 июн 2018, 06:58
Добрыйдень!
В общем модуле выполняю код
ЦитироватьЕсли СтатусИнформационнойБазы=ПредопределенноеЗначение("Перечисление.Тех_СтатусИнформационнойБазы.Актуальная")
      Тогда      СтатусИнформационнойБазы=ПредопределенноеЗначение("Перечисление.Тех_СтатусИнформационнойБазы.ОтправленЗапросПользователю");
      СтатусИнформационнойБазы.Записать();   
   КонецЕсли

Выдает ошибку "Поле объекта недоступно для записи (СтатусИнформационнойБазы)"
Прошу помощи в решении этой ситуации
Вы чего-то не договариваете.
Какой тип значения у переменной "СтатусИнформационнойБазы"?
Что за конфигурация?

has

Tsunami Flow, у ссылки на перечисление нет метода Записать()

Tsunami Flow

Цитата: alexandr_ll от 20 июн 2018, 07:11
Цитата: Tsunami Flow от 20 июн 2018, 06:58
Добрыйдень!
В общем модуле выполняю код
ЦитироватьЕсли СтатусИнформационнойБазы=ПредопределенноеЗначение("Перечисление.Тех_СтатусИнформационнойБазы.Актуальная")
      Тогда      СтатусИнформационнойБазы=ПредопределенноеЗначение("Перечисление.Тех_СтатусИнформационнойБазы.ОтправленЗапросПользователю");
      СтатусИнформационнойБазы.Записать();   
   КонецЕсли

Выдает ошибку "Поле объекта недоступно для записи (СтатусИнформационнойБазы)"
Прошу помощи в решении этой ситуации
Вы чего-то не договариваете.
Какой тип значения у переменной "СтатусИнформационнойБазы"?
Что за конфигурация?
Это реквизит справочника с ссылкой на Перечисление
1С:Предприятие 8.3 (8.3.10.2580)
Центр контроля качества, редакция 2.1 (2.1.1.18)
Copyright © ООО "1C", 2011-2018. Все права защищены
(http://www.1c.ru)
Добавлено: 20 июн 2018, 07:23


Цитата: has от 20 июн 2018, 07:21
Tsunami Flow, у ссылки на перечисление нет метода Записать()
как тогда быть?

alexandr_ll

Метод "Записать" следует применять не к реквизиту справочника, а к объекту справочника.

Tsunami Flow

Цитата: alexandr_ll от 20 июн 2018, 07:36
Метод "Записать" следует применять не к реквизиту справочника, а к объекту справочника.
Можете привести пример

wise

судя по коду из (0)  модуль, вероятно, пользовательский...
а так же КАКОЙ ТипЗнч(СтатусИнформационнойБазы) ?
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

alexandr_ll

Цитата: Tsunami Flow от 20 июн 2018, 07:37
Цитата: alexandr_ll от 20 июн 2018, 07:36
Метод "Записать" следует применять не к реквизиту справочника, а к объекту справочника.
Можете привести пример
Ну вы же сами пишете, что это реквизит справочника, поэтому сначала найдите ссылку на элемент справочника и потом получаете объект. типа того:
СсылкаНаЭлемент=Справочники._НужныйСправочник_.НайтиПоКоду("0001");
    ОбъектСправочника = СсылкаНаЭлемент.ПолучитьОбъект();
   Если ОбъектСправочника.СтатусИнформационнойБазы=ПредопределенноеЗначение("Перечисление.Тех_СтатусИнформационнойБазы.Актуальная")
      Тогда      ОбъектСправочника.СтатусИнформационнойБазы=ПредопределенноеЗначение("Перечисление.Тех_СтатусИнформационнойБазы.ОтправленЗапросПользователю");
    ОбъектСправочника.Записать();
   КонецЕсли   

Похожие темы (5)

Рейтинг@Mail.ru

Поиск