Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
18 апр 2024, 02:11

Не получается вызвать процедуру из общего модуля

Автор ilya31788, 15 июн 2018, 12:22

0 Пользователей и 1 гость просматривают эту тему.

ilya31788

В чём проблема? Не понимаю что не так, пробовал и на сервере, и на клиенте...
Только без воды. 1С только начинаю изучать, нужна инфа по факту.
Код ниже

Ошибка

{МодульУправляемогоПриложения (3,2)}: Переменная не определена (Напоминание)
<<?>>Напоминание. Получить (); (Проверка: Тонкий клиент)

Модуль управляемого приложения

Процедура ПриНачалеРаботыСистемы ()
Напоминание. Получить ();
КонецПроцедуры

Общий Модуль

&НаКлиенте
Процедура Получить ()Экспорт
Выборка = Справочники. Клиенты. Выбрать ();
Пока Выборка. Следующий ()Цикл
Если Выборка. ЭтоГруппа Тогда Продолжить;
КонецЕсли;

Если Месяц (ТекущаяДата ())=Месяц (Выборка. ДатаРождения) Тогда
Если День (ТекущаяДата ())=День (Выборка. ДатаРождения) Тогда
Сообщить (Выборка. Наименование + "из компании " + Выборка. Наименование + "сегодня празднует свой день рождения!");
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецПроцедуры

alexandr_ll

Ну и где определена переменная "Напоминание"?
Что вообще означает
Напоминание.Получить()?

ilya31788

Цитата: alexandr_ll от 15 июн 2018, 12:48
Ну и где определена переменная "Напоминание"?
Что вообще означает
Напоминание.Получить()?

У меня была ошибка в слове "НапоминаниЯ" и надо было поставить галку "Вызов сервера". Всё заработало. Спасибо Вам!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск