Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 апр 2024, 22:55

помогите решить задачу

Автор keks_feo, 29 мар 2011, 15:12

0 Пользователей и 1 гость просматривают эту тему.

keks_feo

добрый день!
помогите решить задачу ...
вот текст

Процедура ВыводТоваров(ФлагСумм)
Если Режим=1 Тогда
Цена= пересчет(Запрос.Цена,Курс1,Курс2);
Иначе     
Цена= 0;
КонецЕсли;
НачКол = запрос.НачКол;
КонКол = запрос.КонКол;
ПрихКол = запрос.ПрихКол;
РасхКол = запрос.РасхКол;   



Если ТипСуммы=1 тогда
НачСум = пересчет(запрос.НачСум,Курс1,Курс2);
КонСум = пересчет(запрос.КонСум,Курс1,Курс2);
ПрихСум = пересчет(запрос.ПрихСум,Курс1,Курс2);
РасхСум = пересчет(запрос.РасхСум,Курс1,Курс2);
ИначеЕсли ТипСуммы=2 тогда
НачСум = пересчет(запрос.НачСум-запрос.НачНац,Курс1,Курс2);
КонСум = пересчет(запрос.КонСум-запрос.КонНац,Курс1,Курс2);
ПрихСум = пересчет(запрос.ПрихСум-запрос.ПрихНац,Курс1,Курс2);
РасхСум = пересчет(запрос.РасхСум-запрос.РасхНац,Курс1,Курс2);
Если (Режим=1)и(НачКол+КонКол+ПрихКол+РасхКол<>0) Тогда
Цена= пересчет((НачСум+КонСум+ПрихСум+РасхСум)/(НачКол+КонКол+ПрихКол+РасхКол),Курс1,Курс2);
КонецЕсли;
Иначе
Цена= ЦенаПоКатегории(контекст,ВыбКатегория,Запрос.Товар);
НачСум = Цена*НачКол;
КонСум = Цена*КонКол;
ПрихСум = Цена*ПрихКол;
РасхСум = Цена*РасхКол;
КонецЕсли;
Единица= Запрос.Товар.БазоваяЕдиница;
Если ВБазовых=2 Тогда                                     
Если запрос.товар.ЕдиницаСклада.Выбран()=1 Тогда
НачКол= НачКол/запрос.Товар.ЕдиницаСклада.Коэффициент;
КонКол= КонКол/запрос.Товар.ЕдиницаСклада.Коэффициент;
ПрихКол= ПрихКол/запрос.Товар.ЕдиницаСклада.Коэффициент;
РасхКол= РасхКол/запрос.Товар.ЕдиницаСклада.Коэффициент;   
Единица= Запрос.Товар.ЕдиницаСклада.Единица;
Цена = Цена*запрос.Товар.ЕдиницаСклада.Коэффициент;
КонецЕсли;
КонецЕсли;
Если ФлагСумм=1 Тогда
Таб.ВывестиСекцию("Строка"); 

ИтогНачВес = ИтогНачВес + НачКол*Запрос.Товар.Вес;
ИтогПрихВес = ИтогПрихВес + ПрихКол*Запрос.Товар.Вес;
ИтогРасхВес = ИтогРасхВес + РасхКол*Запрос.Товар.Вес;
ИтогКонВес = ИтогКонВес + КонКол*Запрос.Товар.Вес;

ИтогНачКол = ИтогНачКол + начКол;
ИтогПрихКол = ИтогПрихКол + прихКол;
ИтогРасхКол = ИтогРасхКол + расхКол;
ИтогКонКол = ИтогКонКол + конКол;
ИтогНачСум = ИтогНачСум + начсум;
ИтогПрихСум = ИтогПрихСум + прихсум;
ИтогРасхСум = ИтогРасхСум + расхсум;
ИтогКонСум = ИтогКонСум + консум;
НПП = НПП + 1;
Иначе
// Таб.ВывестиСекцию("Документ");
КонецЕсли;
КонецПроцедуры    

этот текст выводит все данные которые есть в таблице, а как сделать чтобы выводил только те, где ячейка "РасхКол" не пустая ... 

keks_feo

добавлю
Платформа 7.7 (7.70.025)
Конфигурация  ДС (Трейд ред) (2.7.0)

keks_feo

тю..  :zebzdr: как все просто получилось, спб большое ... буду вникать дальше

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск