Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 апр 2024, 13:00

Не определена дата!Элемент не может быть записан!

Автор polo, 03 мар 2018, 09:58

0 Пользователей и 1 гость просматривают эту тему.

polo

   Если Форма.ТекущаяКолонка()="НормРасхНа1п" Тогда
      врЭл=ТекущийЭлемент();       
      спрВарианты=СоздатьОбъект("Справочник.ВариантыВПаспорте");
      спрВарианты.ИспользоватьВладельца(врЭл);
      спрВарианты.ВыбратьЭлементы();
      Пока спрВарианты.ПолучитьЭлемент()=1 Цикл
         Если спрВарианты.НормРасхНа1п<>врЭл.НормРасхНа1п Тогда
             Если Вопрос("Норма расхода в варианте ("+спрВарианты.НормРасхНа1п+")"+РазделительСтрок+"отличается от исходной нормы в паспорте ("+врЭл.НормРасхНа1п+")"+РазделительСтрок+"Переписать норму в варианте?",4)=7 Тогда
                 Продолжить;
             КонецЕсли;
         КонецЕсли;
         спрВарианты.НормРасхНа1п=НормРасхНа1п;   
         спр=СоздатьОбъект("Справочник.ВариантыВПаспорте")
         спрВарианты.Записать();

Ругается на строку спрВарианты.Записать    пишет Не определена дата!Элемент не может быть записан! Какая дата не могу понять? нужно что бы при изменении значения в одной строке таблицы это значение менялось и во второй

alexandr_ll

Цитата: polo от 03 мар 2018, 09:58
   Если Форма.ТекущаяКолонка()="НормРасхНа1п" Тогда
      врЭл=ТекущийЭлемент();       
      спрВарианты=СоздатьОбъект("Справочник.ВариантыВПаспорте");
      спрВарианты.ИспользоватьВладельца(врЭл);
      спрВарианты.ВыбратьЭлементы();
      Пока спрВарианты.ПолучитьЭлемент()=1 Цикл
         Если спрВарианты.НормРасхНа1п<>врЭл.НормРасхНа1п Тогда
             Если Вопрос("Норма расхода в варианте ("+спрВарианты.НормРасхНа1п+")"+РазделительСтрок+"отличается от исходной нормы в паспорте ("+врЭл.НормРасхНа1п+")"+РазделительСтрок+"Переписать норму в варианте?",4)=7 Тогда
                 Продолжить;
             КонецЕсли;
         КонецЕсли;
         спрВарианты.НормРасхНа1п=НормРасхНа1п;   
         спр=СоздатьОбъект("Справочник.ВариантыВПаспорте")
         спрВарианты.Записать();

Ругается на строку спрВарианты.Записать    пишет Не определена дата!Элемент не может быть записан! Какая дата не могу понять? нужно что бы при изменении значения в одной строке таблицы это значение менялось и во второй
Наверное реквизит "НормРасхНа1п" является периодическим (записывается история реквизита на определенную дату).

Теги:

Похожие темы (2)

Рейтинг@Mail.ru

Поиск