Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 фев 2024, 03:59

Обновление формы динамического диска

Автор Artjomrgv, 09 фев 2018, 03:33

0 Пользователей и 1 гость просматривают эту тему.

Artjomrgv

Коллеги добрый день. Как программно обновить форму динамического списка, при закрытии формы элемента.
То есть когда я закрываю (именно закрываю а не сохраняю) элемент справочника, должна обновиться форма списка этого справочника.


oleg-x

Цитата: Artjomrgv от 09 фев 2018, 03:33
Коллеги добрый день. Как программно обновить форму динамического списка, при закрытии формы элемента.
То есть когда я закрываю (именно закрываю а не сохраняю) элемент справочника, должна обновиться форма списка этого справочника.
Ну как вариант передать параметр при закрытие формы. по которому в форме списка запустится маленький код, обновления формы списка.
Помог, нажми спасибо. Не помог, нажми спасибо :-)
Если у Вас есть проблема, то её уже кто то решил @Yandex, @Google

Artjomrgv

А можешь привести пример, если не сложно.

AIFrame

На форму списка нужно повесить хук на событие ОбработкаОповещения.
При закрытии некой формы, на событии закрытии отправить это Оповещение.

Покажу на своем примере.
Есть некая форма элемента, у которой есть кнопка. Эта кнопка открывает общую форму, в которой нужно ввести пароль.
На форме с вводом пароля стоит обработчик ПриЗакрытии:
&НаКлиенте
Процедура ПриЗакрытии(ЗавершениеРаботы)
Оповестить("ВведенПарольАдминистратораУД","ФормаВводаПароля",Пароль)
КонецПроцедуры


На форме элемента, который ждет ввода пароля, установлен хук на ОбработкуОповещения:
&НаКлиенте
Процедура ОбработкаОповещения(Событие, Источник, Пароль)
Если Событие = "ВведенПарольАдминистратораУД" И Источник = "ФормаВводаПароля" Тогда
ПарольВерный = АдминистраторУчетныхДанныхКлиент.ПроверитьВводПароляАдминистратора(Пароль);
Если ПарольВерный Тогда
ПоказыватьПароли = Истина;
ОбновитьУчетныеДанные();
Элементы.КомандаПоказатьПароли.Заголовок = "Скрыть пароли";
Иначе
ПоказатьПредупреждение(, "Неверный пароль!", 10);
КонецЕсли;
КонецЕсли;
КонецПроцедуры

Как видишь, метод Оповестить() снабжается ключом и источником и отправляет оповещение во все открытые формы. А нужная форма, проверив ключ и источник, выполняет некие действия. Другие формы проигнорируют этот вызов (скорее всего), т.к. ждут других ключей и источников.

Теги: УФ 1С 8.3 

Похожие темы (5)

Рейтинг@Mail.ru

Поиск