Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 мая 2024, 13:03

Сохранение настроек пользователя в форме

Автор evgen.olegovih, 05 фев 2018, 09:49

0 Пользователей и 1 гость просматривают эту тему.

evgen.olegovih

Здравствуйте, уважаемые форумчане!

Подскажите, кто чем сможет.

Имеется Общая Форма печать документов, в которую вставлены элементы: выбор принтера и автомассштаб.
Проблема заключается в том, что настройки галочек и выбора принтера не сохраняются. Как организовать сохранение настроек пользователя?
УТ 10.3, Код формы:
Цитировать//Перем ОриентацияВыбор;
Функция ПолучитьСписокДоступныхПринтеров()
//    Принтеры установленные в системе
    Список = Новый СписокЗначений;
    #Если Клиент Тогда
        Попытка
            КОМОбъект =  Новый COMОбъект ("WScript.Network");
            Принтеры =  КОМОбъект.EnumPrinterConnections();
            шшш = 0;
            Пока шшш < Принтеры.Count()-1 Цикл
                Список.Добавить(Принтеры.Item(шшш+1), Принтеры.Item(шшш+1));
                шшш = шшш + 2;
            КонецЦикла;
        Исключение
            Сообщить(ОписаниеОшибки());
        КонецПопытки;
    #КонецЕсли
    возврат Список;
КонецФункции

Процедура ПриОткрытии()
   ЭлементыФормы.ОриентацияВыбор.СписокВыбора.Добавить("Ландшафт");
   ЭлементыФормы.ОриентацияВыбор.СписокВыбора.Добавить("Портрет");
   ЭлементыФормы.ПолеТабличногоДокумента.ОриентацияСтраницы = ПечатныйДокумент.ОриентацияСтраницы;
   ЭлементыФормы.ПолеТабличногоДокумента.ВставитьОбласть(ПечатныйДокумент.Область());
   
   ЭлементыФормы.ПолеТабличногоДокумента.ОтображатьЗаголовки = Ложь;
   ЭлементыФормы.ПолеТабличногоДокумента.ОтображатьСетку     = Ложь;
   ЭлементыФормы.ПолеТабличногоДокумента.Защита              = Защита;
   ЭлементыФормы.ПолеТабличногоДокумента.ТолькоПросмотр      = Истина;
   ЭлементыФормы.ПолеТабличногоДокумента.ИмяПараметровПечати = ПечатныйДокумент.ИмяПараметровПечати;
   ЭлементыФормы.ПолеТабличногоДокумента.ПовторятьПриПечатиСтроки = ПечатныйДокумент.ПовторятьПриПечатиСтроки;
   если ЭлементыФормы.ПолеТабличногоДокумента.ОриентацияСтраницы=ОриентацияСтраницы.Ландшафт тогда
      ОриентацияВыбор="Ландшафт";
   иначе
      ОриентацияВыбор="Портрет";
   конецесли;
   ЭлементыФормы.Автомасштаб.Значение = ЭлементыФормы.ПолеТабличногоДокумента.АвтоМасштаб;
   ЭлементыФормы.ТекущийПринтер.Заголовок = ЭлементыФормы.ПолеТабличногоДокумента.ИмяПринтера;
   если ЭлементыФормы.ТекущийПринтер.Заголовок="" тогда
   ЭлементыФормы.ТекущийПринтер.Заголовок="Принтер не выбран!!!";   
   конецесли;   
КонецПроцедуры

Процедура КоманднаяПанельФормыОтправитьПоПочте(Кнопка)
   
   УправлениеОтчетами.ОтправитьДокументПоЭлектроннойПочте(ЭлементыФормы.ПолеТабличногоДокумента, Заголовок);
   
КонецПроцедуры


Процедура АвтомасштабПриИзменении(Элемент)
   ЭлементыФормы.ПолеТабличногоДокумента.АвтоМасштаб=ЭлементыФормы.Автомасштаб.Значение;
КонецПроцедуры

Процедура ОриентацияВыборПриИзменении(Элемент)
   // Вставить содержимое обработчика.
   если ОриентацияВыбор="Ландшафт" тогда
      ЭлементыФормы.ПолеТабличногоДокумента.ОриентацияСтраницы=ОриентацияСтраницы.Ландшафт;
   иначе
      ЭлементыФормы.ПолеТабличногоДокумента.ОриентацияСтраницы=ОриентацияСтраницы.Портрет;
   конецесли;

КонецПроцедуры

Процедура ОриентацияВыборНачалоВыбораИзСписка(Элемент, СтандартнаяОбработка)
   // Вставить содержимое обработчика.
КонецПроцедуры

Процедура КоманднаяПанельФормыНаПринтер(Кнопка)
   ЭлементыФормы.ПолеТабличногоДокумента.Напечатать();
КонецПроцедуры

Процедура ТекущийПринтерНажатие(Элемент)
   СписокПринтеров = ПолучитьСписокДоступныхПринтеров();
   если СписокПринтеров.Количество()=0 тогда
      возврат;
   конецесли;
   ВыбранныйПринтер = СписокПринтеров.ВыбратьЭлемент("Выберите принтер");
   если ВыбранныйПринтер=неопределено тогда
      возврат;
   конецесли;
   ЭлементыФормы.ТекущийПринтер.Заголовок=ВыбранныйПринтер.Значение;
     ЭлементыФормы.ПолеТабличногоДокумента.ИмяПринтера = ЭлементыФормы.ТекущийПринтер.Заголовок;   
КонецПроцедуры





Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск