Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 мая 2024, 11:49

Для инвентаризации с помощью сканера

Автор Selenity, 04 мар 2017, 17:05

0 Пользователей и 1 гость просматривают эту тему.

Selenity

Здравствуйте! Есть Розница, редакция 2.2 (2.2.5.23)и 1С:Предприятие 8.3 (8.3.8.2322). На носу инвентаризация. Жадный начальник прикупил из Китая сканер с накопителем (кажись так называется). Пропикать товар и вывести в .txt проблем нет. Но как это ваяние из txt подтянуть в Розницу в документ Инвентаризация. На просторах интернета нашла вот такой листинг для обработки:
Процедура Загрузить(Кнопка)
Текст = Новый ТекстовыйДокумент;
Текст.Прочитать(ИмяФайла,,);
Документ = ЭлементыФормы.ДокументИнвентаризации.Значение.ПолучитьОбъект();
Для НомерСтроки = 1 По Текст.КоличествоСтрок() Цикл
Стр = Текст.ПолучитьСтроку(НомерСтроки);
Результат = Лев(Стр,13);
КолвоВТСД = Число(Прав(Стр,СтрДлина(Стр)-Найти(Стр," ")));
Для Колво = 1 По КолвоВТСД Цикл
Если Не ПустаяСтрока(Результат) Тогда
ПолучитьСерверТО().ОбработатьВведенныйШтрихкод(Результат, Документ.ПолучитьФорму("ФормаДокумента"));
КонецЕсли;
КонецЦикла;
Документ.Записать();
КонецЦикла;
КонецПроцедуры

Процедура ИмяФайлаНачалоВыбора(Элемент, СтандартнаяОбработка)
Режим = РежимДиалогаВыбораФайла.Открытие;   
Диал = Новый ДиалогВыбораФайла(Режим);
Если Диал.Выбрать()Тогда
ЭтаФорма[Элемент.Имя] = Диал.ПолноеИмяФайла;
КонецЕсли;
КонецПроцедуры

Но листинг 2010 года, разумеется для нынешней редакции он не подходит. Подскажите пожалуйста дорогие форумчане начинающему что нужно подправить, чтоб все заработало, ночами уже не сплю. Спасибо милые!
П.С. сканер выдает строки вот такого типа:
46123456789 2 либо
46123456789 ,2

Selenity

Заплачу, только помогите с этой обработкой.

MrLvovsky

Примерчик бы txt на пару десятков записей

alexandr_ll

Цитата: Selenity от 05 мар 2017, 23:02
Заплачу, только помогите с этой обработкой.
Можно использовать типовую обработку "Загрузка данных из табличного документа" https://cloud.mail.ru/public/6Y1j/LecW9xEHh, она работает с текстовыми файлами

MrLvovsky

Цитата: alexandr_ll от 07 мар 2017, 09:41
Цитата: Selenity от 05 мар 2017, 23:02
Заплачу, только помогите с этой обработкой.
Можно использовать типовую обработку "Загрузка данных из табличного документа" https://cloud.mail.ru/public/6Y1j/LecW9xEHh, она работает с текстовыми файлами

Я так понимаю там не вносить данные из таблицы надо, а сравнивать с существующими карточками номенклатуры.
Тупенький сканер считывает баркод, переводит его в число и вписывает в тхт.
Этот набор тхт надо считать, вывести в таблицу значений, второй колонкой вывести количество (количество дублей баркодов в тхт).
Потом двумя запросами вытащить из регистра остатков на складе сначала номенлкатуру, которая входит в список тхт (сравнивать по реквизиту с баркодом в карточке номенклатуры) и которая туда не входит (методом "от обратного").
По результату первого запроса сравнить остатки с количеством "дублей" по каждой номенклатуре и вывести различия. Второй запрос можно вывести отдельно или соединить в один список.

Схема примерная, возможно не оптимизированная, придумал пока писал =)

Но судя по всему ТСу уже не актуально.


Selenity

Цитата: MrLvovsky от 06 мар 2017, 14:09
Примерчик бы txt на пару десятков записей
Так там записи внутри txt до доодурения просты
1234567891023 ,3
1234567891234 ,4
И так по всему документу. Просто в блокноте эти записи в столбик )
Добавлено: 09 мар 2017, 23:37


Цитата: MrLvovsky от 07 мар 2017, 13:46
Цитата: alexandr_ll от 07 мар 2017, 09:41
Цитата: Selenity от 05 мар 2017, 23:02
Заплачу, только помогите с этой обработкой.
Можно использовать типовую обработку "Загрузка данных из табличного документа" https://cloud.mail.ru/public/6Y1j/LecW9xEHh, она работает с текстовыми файлами

Я так понимаю там не вносить данные из таблицы надо, а сравнивать с существующими карточками номенклатуры.
Тупенький сканер считывает баркод, переводит его в число и вписывает в тхт.
Этот набор тхт надо считать, вывести в таблицу значений, второй колонкой вывести количество (количество дублей баркодов в тхт).
Потом двумя запросами вытащить из регистра остатков на складе сначала номенлкатуру, которая входит в список тхт (сравнивать по реквизиту с баркодом в карточке номенклатуры) и которая туда не входит (методом "от обратного").
По результату первого запроса сравнить остатки с количеством "дублей" по каждой номенклатуре и вывести различия. Второй запрос можно вывести отдельно или соединить в один список.

Схема примерная, возможно не оптимизированная, придумал пока писал =)

Но судя по всему ТСу уже не актуально.
Здравствуйте! Не не не все актуально! Просто открыто три браузера и в каждом по 70 вкладок. Я тупо потеряла форум. ))) Да все вы правильно и поняли и придумали. Задача казалась тривиальная НО..... Загрузка из Табличного документа не умеет работать с txt. Ну что пол беды, труда не составит ручками txt переделать в xls. Проблема в том что в обработке нет загрузки по штрихкоду, а это все что есть, ш/к и количество и все. В обработке обязательно должно быть название номенклатуры. На нем все завязано, а его нет в txt/ Рыла лопатой весь интернет. Нарыла только вот такой костыль-нога - Обработка Загрузка из файла умеет подтягивать в документ Установка цен товар по ш/к, если извернуться и в xls файл вставить список ш/к в столбик, номенклатура определится. Затем скопировать список номенклатуры и вставить в изначальный файл, а потом все это протянуть через Загрузка из табличной части в документ Пересчет товаров, может получится...но 1с Предприятие автоматизация и все круто, а тут реальный костыль-нога. И то не факт что получится. Я ученик 1с программирования и до этого уровня мне еще далеко, а инвентаризация в вс уже...
Пришла мысль поковырять не тот код что выше, а код у Загрузки из файла, подтянуть туда документ Пересчет товаров и количество, его там нет и в принципе сгодная модель.

alex0402

Цитата: Selenity от 09 мар 2017, 23:18Загрузка из Табличного документа не умеет работать с txt.
а с xls или cvs (точно не помню, текст с разделителями). Этот файл можно открыть Экселем и сохранить как xls.
Спасибо за Сказать спасибо

Selenity

Цитата: alex0402 от 10 мар 2017, 09:59
Цитата: Selenity от 09 мар 2017, 23:18Загрузка из Табличного документа не умеет работать с txt.
а с xls или cvs (точно не помню, текст с разделителями). Этот файл можно открыть Экселем и сохранить как xls.
Да любой файл можно так сохранить. Проблема с конвертацией решилась. В настройках недосканера нашла пункт выгружать в txt или xls. Но главную проблему это все равно не решит (((

alex0402

осталось написать свою обработку или модернизировать/настроить стандартную. делов-то! ;)
Спасибо за Сказать спасибо

Selenity

Короче ничего вообще не решилось! Обработка Загрузка из табличного полностью перезаписывает документ Пересчет товаров а не добавляет товар. в итоге остаток другой получается. тот который по инвентаризации, а не по складу

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск