Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 апр 2024, 22:45

Подстановка значения в табличную часть документа из реквизита справочника

Автор lelik13121991, 30 окт 2016, 23:07

0 Пользователей и 1 гость просматривают эту тему.

lelik13121991

Добрый день!
Собственно есть Справочник Услуги, в нем реквизит Баллы.
Есть документ заявки с табличной частью. В ней 2 реквизита - услуга (значение выбирается из справочника услуги) и те же самые баллы.
Бьюсь с задачей автоматической подстановки значения баллов из справочника, при выборе услуги - никак не могу разобраться с синтаксисом процедуры. Как я понял, действовать нужно через процедуру "приИзменении", но вот правильно это сделать не получается :((
1С 8.3
Буду безумно благодарен если более опытные люди подскажут.
Копию конфигурации прилагаю

Андрей Сисюкин

Доброго времени суток.

Во-первых, тебе надо баллы, а написано: Строка.Цена = Строка.Товар.Цена1;
Во, вторых, обращение к данным формы происходит через "Элементы", а не как в обычных формах, ЭлементыФормы.
и в третьих, самое главное - на клиенте нет работы с объектами базы (справочники, документы...
только с функций и процедур, что имеют &НаСервере.

В итоге у тебя должно быть как-то так:

&НаСервере
функция получить_баллы(услуга)
возврат Услуга.Баллы;
КонецФункции

&НаКлиенте
Процедура УслугиУслугаПриИзменении(Элемент)
Строка = Элементы.Услуги.ТекущиеДанные;
Если Строка <> Неопределено Тогда
Строка.Баллы = получить_баллы(Строка.Услуга);
КонецЕсли
КонецПроцедуры

lelik13121991


Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск