Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 фев 2024, 00:09

Регистры

Автор 6aToH, 16 янв 2011, 17:56

0 Пользователей и 1 гость просматривают эту тему.

6aToH

Прошу сильно не пинать т.к. с регистрами я не работал.
Читал про них пробовал написать но мне выходит пустая таблица.
Подскажите как сделать отчет который выводил бы список контрагентов по которым за выбранный период была реализация товаров?
Выберать необходимо из регистров.
Регистр Реализованный товар

Имерения
организация
основание
тмц
партия

ДокПродажи
Ресурсы
Кол-во
Стоимость



вот это что выдать должно?
Процедура Сформировать()
Перем Запрос, ТекстЗапроса, Таб;
//Создание объекта типа Запрос
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса =
"//{{ЗАПРОС(Сформировать)
|Период с ВыбНачПериода по ВыбКонПериода;
|Владелец = Регистр.РеализованныйТовар.Основание.Владелец;
|Количество = Регистр.РеализованныйТовар.Количество;
|ПродСтоимость = Регистр.РеализованныйТовар.ПродСтоимость;
|Группировка Владелец упорядочить по Владелец.РегионПродаж;
|"//}}ЗАПРОС
;
// Если ошибка в запросе, то выход из процедуры
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;

// Подготовка к заполнению выходных форм данными запроса
Таб = СоздатьОбъект("Таблица");
Таб.ИсходнаяТаблица("Сформировать");
// Заполнение полей "Заголовок"
Таб.ВывестиСекцию("Заголовок");
Состояние("Заполнение выходной таблицы...");
Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
Пока Запрос.Группировка(1) = 1 Цикл
// Заполнение полей Владелец
Таб.ВывестиСекцию("Владелец");
КонецЦикла;
// Вывод заполненной формы
Таб.ТолькоПросмотр(1);
Таб.Показать("Сформировать", "");
КонецПроцедуры


6aToH

т.е. я вроде правильно сделал. ясно значит у меня база глючная

6aToH

короче вот такая задача:
Нужно отобразить Реализованный товар за период в разрезе контрагента.
и сгруппировать по регионам продаж(поле справочника контрагент)

Дайте ссылку если у кого есть, где разжеваны регистры и как с ними работать!
Желательно с примерами!

Теги:

Похожие темы (1)

Рейтинг@Mail.ru

Поиск