Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 июн 2024, 17:34

Грабли: Как работать со справочником из модуля формы?

Автор sofabeat, 09 ноя 2010, 14:48

0 Пользователей и 1 гость просматривают эту тему.

sofabeat

Хочу в табличной части документа, чтобы ПриИзменении (Выборе) Услуги соответственно отображалась Цена услуги. Изменяю реквизит ТабЧасти (СправочникСсылка.Услуги). В этом же справочники содержится нужная мне цена.

ФормаДокумента
&НаКлиенте
Процедура УслугаПриИзменении(Элемент)
     СтрокаТабЧасти = Элементы.Услуги.ТекущиеДанные;
     Усл = СтрокаТабЧасти.Услуга;
     Цена = ОбщийМодуль.УзнатьЦену(Усл);
КонецПроцедуры

ОбщийМодуль - Модуль Глобальный
&НаКлиентеНасервере
Функция
     Для каждого Услуга из Справочники.Услуги Цикл
           если Услуга = Усл тогда
           возврат Справочники.Услуги.Цена;
           конецесли;
           конеццикла;
КонецФункции

Натыкаюсь либо на то, что Справочники не знает клиент, либо на то, что функцию не знает клиент. Как это сделать по-человечески?

progmikon


&НаКлиенте
Процедура УслугаПриИзменении(Элемент)
    СтрокаТабЧасти = Элементы.Услуги.ТекущиеДанные;
    Усл = СтрокаТабЧасти.Услуга;
    Цена = ВозвратЦены(Усл);
КонецПроцедуры

&НаСервере
Функция ВозвратЦены(Номенклатура)
      Возврат Номенклатура.Цена;
КонецФункции

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск