Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
13 апр 2024, 03:47

пустые строки в оборотно-сальдовой ведомости

Автор Людмила Р., 21 окт 2010, 14:51

0 Пользователей и 1 гость просматривают эту тему.

Людмила Р.

Всем добрый день!

Проблема в том, что очень надо сделать так что бы в оборотно-сальдовой ведомости (ОСВ) выходили все счета, даже те что не имеют сальдо на начало и конец периода и оборотов по периоду. Необходимость появилась потому что бухгалтер после формирования ОСВ в 1С импортирует её в эксель и используя формулу сравнивает с данными имеющими такую же структуру. (для чего не знаю) Пересмотрела весь модуль ОСВ нашла несколько условий похожих на удаление пустых строк, но закоментив их результат не получился. 


Спасибо за ответы ) 

Людмила Р.

Думала что написала  :nhsrm:
1С Предприятие 7.7 (сетевая версия)
Бухгалтерский учет для Казахстана (7.7)

prog1c7.7

Даже те что не имеют оборотов между счетами?

Людмила Р.

Цитата: prog1c7.7 от 22 окт 2010, 09:01
Даже те что не имеют оборотов между счетами?

Получается нужны все какие только возможны, порядок и группировку счетов уже получилось изменить на нужный, а вот что бы все выходили не получается.

prog1c7.7

в цикле выборки итогов  есть  проверка на  СНД СКК ДО КО и прочее
например:
Если ИтогиНеРавныНулю(РазвСальдоИт, 1) = 0 Тогда
    Продолжить;
КонецЕсли;
Помоему так если не ошибаюсь

Людмила Р.

Цитата: prog1c7.7 от 22 окт 2010, 09:18
в цикле выборки итогов  есть  проверка на  СНД СКК ДО КО и прочее
например:
Если ИтогиНеРавныНулю(РазвСальдоИт, 1) = 0 Тогда
    Продолжить;
КонецЕсли;
Помоему так если не ошибаюсь

Что нибудь подобное не нашла  :fdbsdfbsd:


По моему это где то тут?
   Пока Субсчета.ПолучитьСчет(0) = 1 Цикл
         // Выберем итоги по текущему субсчету
         Если Ит.ПолучитьСчет(, Субсчета.ТекущийСчет()) = 1 Тогда
            НайденоПоСчету = 1;
            Если ПарамВалюта <> ПолучитьПустоеЗначение() Тогда
               // Выберем итоги по уаказанной валюте
               НайденоПоСчету = Ит.ПолучитьВалюту(, ПарамВалюта);
            КонецЕсли;
            Если НайденоПоСчету = 1 Тогда
               Если СальдоПолучить(Субсчета.ТекущийСчет(), ВремСНД, ВремСНК, ВремСКД, ВремСКК, ТипСуммы, ПарамВалюта) = 1 Тогда
                  Найдено = 1;
                  СНД = СНД + ВремСНД;
                  СНК = СНК + ВремСНК;
                  СКД = СКД + ВремСКД;
                  СКК = СКК + ВремСКК;
               КонецЕсли;
            КонецЕсли;
         КонецЕсли;
      КонецЦикла;

prog1c7.7

это ОСВ или ОСВ по счету?
Модуль оборотки на мыло кинь.

Людмила Р.


prog1c7.7


Людмила Р.


Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск