Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 мая 2024, 11:58

Добавляется пустая строка в отчете

Автор rudzeeff, 03 мая 2015, 13:44

0 Пользователей и 1 гость просматривают эту тему.

rudzeeff

Процедура КнопкаСформироватьНажатие(Кнопка)
   Запрос = Новый Запрос;
   Запрос.Текст ="ВЫБРАТЬ
                 |   ТоварыОрганизацийОстатки.КоличествоОстаток КАК КоличествоОстаток,
                 |   ЦеныНоменклатурыСрезПоследнихЗакупочные.Цена КАК Закупочная,
                 |   ЦеныНоменклатурыСрезПоследнихРозничные.Цена КАК Розничная,
                 |   ТоварыОрганизацийОстатки.Номенклатура КАК Номенклатура,
                 |   ТоварыОрганизацийОстатки.Организация КАК Организация
                 |ИЗ
                 |   РегистрНакопления.ТоварыОрганизаций.Остатки(
                 |         &КонДата,
                 |         Организация = &Организация
                 |            И Номенклатура В ИЕРАРХИИ (&Номенклатура)) КАК ТоварыОрганизацийОстатки
                 |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры.СрезПоследних(&КонДата, ) КАК ЦеныНоменклатурыСрезПоследнихЗакупочные
                 |      ПО (ЦеныНоменклатурыСрезПоследнихЗакупочные.ТипЦен = &Закупочные)
                 |         И ТоварыОрганизацийОстатки.Номенклатура = ЦеныНоменклатурыСрезПоследнихЗакупочные.Номенклатура
                 |      ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ЦеныНоменклатуры.СрезПоследних(&КонДата, ) КАК ЦеныНоменклатурыСрезПоследнихРозничные
                 |      ПО (ЦеныНоменклатурыСрезПоследнихРозничные.ТипЦен = &Розничные)
                 |         И ТоварыОрганизацийОстатки.Номенклатура =                        ЦеныНоменклатурыСрезПоследнихРозничные.Номенклатура
                 |
                 |СГРУППИРОВАТЬ ПО
                 |   ТоварыОрганизацийОстатки.Номенклатура,
                 |   ТоварыОрганизацийОстатки.Организация,
                 |   ТоварыОрганизацийОстатки.КоличествоОстаток,
                 |   ЦеныНоменклатурыСрезПоследнихЗакупочные.Цена,
                 |   ЦеныНоменклатурыСрезПоследнихРозничные.Цена
                 |ИТОГИ ПО
                 |   ОБЩИЕ";
             
      Запрос.УстановитьПараметр("КонДата",КонецДня(КонДата));       
      Запрос.УстановитьПараметр("Номенклатура",Номенклатура);
      Запрос.УстановитьПараметр("Организация",Организация);
      Запрос.УстановитьПараметр("Закупочные",Справочники.ТипыЦенНоменклатуры.НайтиПоНаименованию("Закупочные"));
      Запрос.УстановитьПараметр("Розничные",Справочники.ТипыЦенНоменклатуры.НайтиПоНаименованию("Розничные"));
   
      тз=Запрос.Выполнить().Выгрузить();
     Т=Новый ТабличныйДокумент;
   Макет=ПолучитьМакет("Макет");
   ОблШапка=Макет.ПолучитьОбласть("Шапка");
   ОблСтрока=Макет.ПолучитьОбласть("Строка");
   Т.Вывести(ОблШапка);
   тз=Запрос.Выполнить().Выгрузить();
   пп=0;
   
   Для каждого стр из тз Цикл
      ОблСтрока.Параметры.Заполнить(стр);
      пп=пп+1;
      ОблСтрока.Параметры.пп=пп;
      Т.Вывести(ОблСтрока);
                  
   КонецЦикла;           
   
   Т.АвтоМасштаб=Истина;
   Т.ОтображатьЗаголовки=Ложь;
   Т.ОтображатьСетку=Ложь;
   Т.Показать();



№   Номенклатура   Остатки   Закупочная   Розничная   СуммаЗакупочная   СуммаРозничная
1                  
2   Вино МОНАСТЫРСКАЯ ТРАПЕЗА МЗВВ кр п/сл 10-12% 2л   2   221,84   369      



Первая строка пустая, как исправить подскажите) Спасибо за внимание.

RomanCasper

Я сильно не вникал, но заметил что у вас дважды вызывается
тз=Запрос.Выполнить().Выгрузить();

Попробуйте 1 раз, может поможет)

cska-fanat-kz

RomanCasper, не поможет :P

rudzeeff, у вас запрос с итогами, т.е. в исходной таблице первая строка - строка общих итогов.
обойдите результат запроса двойным циклом. примерно так:
ВыборкаИтоги = Запрос.Выполнить().Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);
Пока ВыборкаИтоги.Следующий() Цикл
    ВыборкаДетальные = ВыборкаИтоги.Выбрать();
    Пока ВыборкаДетальные.Следующий() Цикл
        ОблСтрока.Параметры.Заполнить(ВыборкаДетальные);
        ...
    КонецЦикла;
КонецЦикла;
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск