Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
19 апр 2024, 11:55

Помогите подправить отчет

Автор Agla, 27 фев 2014, 12:37

0 Пользователей и 1 гость просматривают эту тему.

Agla

Есть отчет по продажам по месяцам в 1С 7.7 типовая бузгалтерия
1)отчет выводится , а месяц пишется как цифра, а нужно как название,
2)данные выводятся в столбец, а нужно слева товар, а справа по месяцам количество с суммой.

Mitay_D

1. Формат(Запрос.Дата,"ДММММ")
   Формат(ДатаМесяц(ДатаМ),"ДММММ") 
2. вроде как выводит товар слева, а все остальное справа.

Agla

Цитата: Mitay_D от 27 фев 2014, 13:08
1. Формат(Запрос.Дата,"ДММММ")
   Формат(ДатаМесяц(ДатаМ),"ДММММ") 
2. вроде как выводит товар слева, а все остальное справа.
2. следующие месяца выводятся вниз как столбец, а нужно напротив товара вправо
Добавлено: 27 фев 2014, 14:31


Цитата: Agla от 27 фев 2014, 13:43
Цитата: Mitay_D от 27 фев 2014, 13:08
1. Формат(Запрос.Дата,"ДММММ")
   Формат(ДатаМесяц(ДатаМ),"ДММММ") 
2. вроде как выводит товар слева, а все остальное справа.
2. следующие месяца выводятся вниз как столбец, а нужно напротив товара вправо
c 1 пунктом не получается незнаю в какое место дописать.

Mitay_D

1.       

Если месяца = 1  Тогда
  ДатаМ = Запрос.Дата;
  Товар=Запрос.Товар;//дмитриева
  Месяц=Формат(ДатаМесяц(ДатаМ),"ДММММ");   
Иначе
  Месяц = Формат(Запрос.Дата,"ДММММ");
КонецЕсли;

2. сделайте пример в екселе как вам надо с номенклатурой и месяцами.

Agla

Цитата: Mitay_D от 28 фев 2014, 06:26
1.       

Если месяца = 1  Тогда
  ДатаМ = Запрос.Дата;
  Товар=Запрос.Товар;//дмитриева
  Месяц=Формат(ДатаМесяц(ДатаМ),"ДММММ");   
Иначе
  Месяц = Формат(Запрос.Дата,"ДММММ");
КонецЕсли;

2. сделайте пример в екселе как вам надо с номенклатурой и месяцами.
Добавлено: 28 фев 2014, 16:07


Цитата: Agla от 28 фев 2014, 15:56
Цитата: Mitay_D от 28 фев 2014, 06:26
1.       

Если месяца = 1  Тогда
  ДатаМ = Запрос.Дата;
  Товар=Запрос.Товар;//дмитриева
  Месяц=Формат(ДатаМесяц(ДатаМ),"ДММММ");   
Иначе
  Месяц = Формат(Запрос.Дата,"ДММММ");
КонецЕсли;

2. сделайте пример в екселе как вам надо с номенклатурой и месяцами.
Вставив Ваш код все равно не выводит название месяца.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск