Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
13 апр 2024, 02:42

Тип не определен

Автор fagust19821, 15 фев 2014, 15:39

0 Пользователей и 1 гость просматривают эту тему.

fagust19821

{Обработка.Тест.Форма.Форма.Форма(6,31)}: Тип не определен (ДиалогВыбораФайла)
      ДиалогОткрытияФайла = Новый <<?>>ДиалогВыбораФайла(Режим);
Мобильное приложение содержит синтаксические ошибки.
не могу понять почему эта ошибка
&НаКлиенте
Процедура Загрузить(Команда)
   Если  ПодключитьРасширениеРаботыСФайлами() Тогда
      Режим = РежимДиалогаВыбораФайла.Открытие;
      ДиалогОткрытияФайла = Новый ДиалогВыбораФайла(Режим);
      ДиалогОткрытияФайла.ПолноеИмяФайла = "";
      Фильтр = "Таблица(*.xls)|*.xls";
      ДиалогОткрытияФайла.Фильтр               = Фильтр;
      ДиалогОткрытияФайла.МножественныйВыбор   = Ложь;
      ДиалогОткрытияФайла.Заголовок            = "Выберите файл c описью вложения";
      
      Если ДиалогОткрытияФайла.Выбрать() Тогда
         ПутьКФайлу = ДиалогОткрытияФайла.ПолноеИмяФайла;
      Иначе
         Возврат;
      КонецЕсли;
      
      Попытка
         Excel = Новый COMОбъект("Excel.Application");
         Excel.WorkBooks.Open(ПутьКФайлу);
         ExcelЛист = Excel.Sheets(1);
      Исключение
         Сообщить("Ошибка открытия файла!");
         Возврат;
      КонецПопытки;
      
      ТекущаяСтрока = 1;
      ЧитатьПо=ExcelЛист.Usedrange.Rows.Count;   КонецЕсли;
   ТекущаяСтрока = 1;

   ЧитатьПо=ExcelЛист.Usedrange.Rows.Count;
      Для н=ТекущаяСтрока по ЧитатьПо Цикл
         А=1; В=2;
         Элементы.Тест.ДобавитьСтроку();
         Элементы.Тест.ТекущиеДанные.Вопрос=А;
         Элементы.Тест.ТекущиеДанные.Ответ=В;
         Элементы.Тест.ТекущиеДанные.Вопрос=" "+сокрЛП(ExcelЛист.Cells(н,1).Value);
         Элементы.Тест.ТекущиеДанные.Ответ=" "+сокрЛП(ExcelЛист.Cells(н,2).Value);
         КонецЦикла;
КонецПроцедуры


wise

ДиалогВыбораФайла
Описание:

Предназначен для работы с диалогом специального вида для открытия файла или нескольких файлов, сохранения файла или выбора каталога.
Для работы метода в режиме запуска "Веб-клиент", необходимо предварительно подключить расширение работы с файлами.
Представьте себе, какая была бы тишина, если бы люди говорили только то, что знают

belu

Да :( работает везде кроме мобильного приложения. Может в мобильном это вообще не работает :dfbsdfbsdf:
Добавлено: 17 фев 2014, 10:59


Есть такая статья: http://infostart.ru/public/155226/
Не стал её читать, ключевое в ней вот это:

Беглое изучение справки дало неутешительный результат - на мобильной платформе не поддерживается "ДиалогВыбораФайла".

Теги:

Похожие темы (1)

Рейтинг@Mail.ru

Поиск