Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
20 июн 2024, 19:16

Удалить лишние пробелы

Автор DmitriyF, 27 дек 2013, 23:58

0 Пользователей и 1 гость просматривают эту тему.

DmitriyF

Здравствуйте.
Кусок Кода
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ШтрихкодыНоменклатуры.Штрихкод
      |ИЗ
      |   РегистрСведений.ШтрихкодыНоменклатуры КАК ШтрихкодыНоменклатуры";

   РезультатЗапроса = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      
      НаборЗаписей = РегистрыСведений.ШтрихкодыНоменклатуры.СоздатьНаборЗаписей();
      НаборЗаписей.Отбор.ШтрихКод.Установить(ВыборкаДетальныеЗаписи.ШтрихКод);
      НаборЗаписей.Прочитать();
      ШтрихКодБезПробелов = СтрЗаменить(ВыборкаДетальныеЗаписи.Штрихкод," ","");
      Запись.Штрихкод = ШтрихКодБезПробелов;
Подскажите почему Функция СтрЗаменить упорно не убирает пробелы из штрихкода? Каким другим способом можно реализовать данную процедуру?  Сейчас штрихкод выглядит так 4 600 082 200 453

LordWizard

Сначала замени на строковую, а потом удаляй пробелы. СтрЗаменить() работает только на строковых переменных.

ПеремСтрока = СокрЛП(Строка(Перем));
ПеремПолучаем = СтрЗаменить(ПеремСтрока," ","");

Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

DmitriyF

Цитата: LordWizard от 28 дек 2013, 00:29
Сначала замени на строковую, а потом удаляй пробелы. СтрЗаменить() работает только на строковых переменных.

ПеремСтрока = СокрЛП(Строка(Перем));
ПеремПолучаем = СтрЗаменить(ПеремСтрока," ","");


Так ШтрихКод это и есть строка а не число.

LordWizard

Там - это где? Какая конфигурация?
Добавлено: 28 дек 2013, 01:19


Фрагмент процедуры формирования нового ШтрихКода из УТ 10:


ТекКод = ?(Выборка.Код = NULL, 1, Мин(ОбщегоНазначения.ПривестиСтрокуКЧислу(Выборка.Код) + 1, 99999999));

Штрихкод = "2" + ПрефиксШтучногоТовара + ПрефиксВнутреннегоШтрихкода + Формат(ТекКод, "ЧЦ=8; ЧВН=; ЧГ=");
Штрихкод = Штрихкод + КонтрольныйСимволEAN(ШтрихКод, 13);

и ты будешь утверждать после этого, что он строка? :xfbnsdfb:
Добавлено: 28 дек 2013, 01:30


ХЗ, может и строка. Но почему функция в этом месте не работает - непонятно.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

DmitriyF

Цитата: LordWizard от 28 дек 2013, 01:11
Там - это где? Какая конфигурация?
Добавлено: 28 дек 2013, 01:19


Фрагмент процедуры формирования нового ШтрихКода из УТ 10:


ТекКод = ?(Выборка.Код = NULL, 1, Мин(ОбщегоНазначения.ПривестиСтрокуКЧислу(Выборка.Код) + 1, 99999999));

Штрихкод = "2" + ПрефиксШтучногоТовара + ПрефиксВнутреннегоШтрихкода + Формат(ТекКод, "ЧЦ=8; ЧВН=; ЧГ=");
Штрихкод = Штрихкод + КонтрольныйСимволEAN(ШтрихКод, 13);

и ты будешь утверждать после этого, что он строка? :xfbnsdfb:
Добавлено: 28 дек 2013, 01:30


ХЗ, может и строка. Но почему функция в этом месте не работает - непонятно.
УТ 11.
Штрихкод строка длина 200

LordWizard

Попробуй вставить &НаКлиентеНаСервере может попустит. :xfbnsdfb:
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

DmitriyF

Цитата: LordWizard от 28 дек 2013, 14:00
Попробуй вставить &НаКлиентеНаСервере может попустит. :xfbnsdfb:
Так работать не будет скорее всего.
Вообщем вот полный код

&НаКлиенте
Процедура ПривестиШтрихкод(Команда)
   ПривестиШтрихкодНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПривестиШтрихкодНаСервере()
   
   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   ШтрихкодыНоменклатуры.Штрихкод,
      |   ШтрихкодыНоменклатуры.Номенклатура
      |ИЗ
      |   РегистрСведений.ШтрихкодыНоменклатуры КАК ШтрихкодыНоменклатуры";

   РезультатЗапроса = Запрос.Выполнить();

   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      
      НаборЗаписей = РегистрыСведений.ШтрихкодыНоменклатуры.СоздатьМенеджерЗаписи();
      ШтрихКодБезПробелов = СтрЗаменить(СокрЛП(Строка(ВыборкаДетальныеЗаписи.Штрихкод))," ","");
      НаборЗаписей.Штрихкод = ШтрихКодБезПробелов;
      НаборЗаписей.Номенклатура = ВыборкаДетальныеЗаписи.Номенклатура;
      НаборЗаписей.Записать();
      
   КонецЦикла;
   
КонецПроцедуры

LordWizard

Откуда у тебя пробелы берутся? Как-то некорректно считываются?
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

ldo

Цитата: LordWizard от 28 дек 2013, 14:00
Попробуй вставить &НаКлиентеНаСервере может попустит. :xfbnsdfb:
причем тут клиент серверы,
там скорее всего непрерывный пробел, довольно распространенная проблема, попробуйте
ПеремПолучаем = СтрЗаменить(ПеремСтрока, Символы.НПП, "");

DmitriyF

Цитата: LordWizard от 28 дек 2013, 17:24
Откуда у тебя пробелы берутся? Как-то некорректно считываются?
Так загружает из Экселя, причем там нет пробелов.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск