Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
17 июн 2024, 13:25

Добавления макета типа Active Document.

Автор TreeDogNight, 25 дек 2013, 15:26

0 Пользователей и 1 гость просматривают эту тему.

TreeDogNight

В документе Приём на работу, нужно создать макет Active document, поместив в него Приказ о приёме на работу. Нужно чтобы ФИО в этом приказе изменялись на указанные в документе ФИО. Как это можно осуществить?
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

TreeDogNight

Подскажите, существует ли какое-нибудь пособие по работе с макетами?
Cегодня не все могут провести завтрашним числом. Вернее, не только лишь все - мало кто может это сделать.

LordWizard

Думаю, что в пособии по разработке. В стандартной поставке "Конфигурирование и администрирование" вроденет. хотя все может быть.
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

ingenium

Цитата: TreeDogNight от 25 дек 2013, 15:26
В документе Приём на работу, нужно создать макет Active document, поместив в него Приказ о приёме на работу. Нужно чтобы ФИО в этом приказе изменялись на указанные в документе ФИО. Как это можно осуществить?

Какая конфигурация и какой макет?
Компания Ingenium
http://ingenium43.ru

markgenuine

При создании печатной формы, добавляем макет в виде ActiveDocument.
То что нужно заменить к примеру в документе пишем %ЗаменитьЭто% и пошло, поехало в модуле объекта.

Процедура Напечатать Экспорт()
..............................
АктивныйДокумент = ПолучитьМакет(Макет);
КомОбъект = АктивныйДокумент.Получить();
..............................
КонецПроцедуры

Процедура ПрочитатьЗакладки()
..............................
ВывестиЗакладки("%ЗаменитьЭто%", Заполняем);
..............................
КонецПроцедуры

Процедура ВывестиЗакладки(НаименованиеЗакладки, ЗначениеЗакладки)
Заменить = КомОбъект.Content.Find;
Заменить.Execute(НаименованиеЗакладки,,,,,,,,,СокрЛП(ЗначениеЗакладки),2);
КонецПроцедуры




анна1992

а куда именно записывается этот код? при записи или в процедуру печати?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск