Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
17 июн 2024, 14:07

Простая обработка

Автор lindstorm, 15 дек 2013, 21:04

0 Пользователей и 1 гость просматривают эту тему.

lindstorm

Здравствуйте. Я в 1С новичок, поэтому заранее извиняюсь за беспокойство.
У меня 1С конфигурация связана с выдачей кредитов  - клиент заполняет анкету о доходах,
данные заносятся в справочник и оттуда данные нужно считать, решив  - давать кредит или нет.
Я создал обработку - на ней выбирается клиент(ссылка на справочник Клиенты) и пытаюсь в поле Реквизит1 вынести значение. Но ничего не выводит..

&НаКлиенте
Процедура ДатьКредит(Команда)
   Клиент = Объект.Клиент;
   ДатьКредитНаСервере(Клиент);
КонецПроцедуры

&НаСервере
Процедура ДатьКредитНаСервере(Клиент)
      Запрос = Новый Запрос;
      Запрос.УстановитьПараметр("Клиент", Клиент);
      Запрос.Текст = "
      |ВЫБРАТЬ
      |     Анкеты.ЕжемесячныеДоходы
      |ИЗ Справочник.АнкетыКлиентов КАК Анкеты
      |ГДЕ
      |    Анкеты.ФИО =  &Клиент";
      Рез =  Запрос.Выполнить().Выбрать();
      Пока Рез.Следующий()  Цикл
         Реквизит1 = Рез;
      КонецЦикла;
      
Скажите пожалуйста, что неправильно? И возможно тут нужна не обработка.
         

sdilshod

    |     Анкеты.ЕжемесячныеДоходы
      |ИЗ Справочник.АнкетыКлиентов КАК Анкеты
      |ГДЕ
      |    Анкеты.ФИО =  &Клиент";
      Рез =  Запрос.Выполнить().Выбрать();
      Пока Рез.Следующий()  Цикл
         Реквизит1 = Рез; //Здесь надо передать поля из выборки результата запроса. [b]Рез.ЕжемесячныеДоходы[/b]

      КонецЦикла;

LordWizard

Я бы еще до вывода результата в тексте запроса дописал бы условие на проверку по количеству доходов - можно давать кредит или нет!
Правильно ведите учет или пишите программы и вам воздастся!...

(Кстати - кнопочку Сказать Спасибо - никто не отменял)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск