Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
19 апр 2024, 12:24

Установить значение реквизита

Автор Zeus_God, 10 ноя 2013, 21:56

0 Пользователей и 1 гость просматривают эту тему.

Zeus_God

Здравствуйте!
Подскажите, пожалуйста, как установить значение реквизита. Делаю внешнюю обработку для ЗУП 2.5 документ "Справка о заработке для расчета пособий". Фрагмент кода:

          Пока РезультатЗапроса.Следующий() Цикл
ТабНомСотр = СокрЛП(РезультатЗапроса.Код);
ТабНомСотрЧисло = Число(ТабНомСотр);
КодВДок = СокрЛП(Лист.Cells(СтрокаФайла,ТабельныйНомер).Value);
КодВДокЧисло = Число(КодВДок);
НовыйДокумент.Записать();

Если ТабНомСотрЧисло = КодВДокЧисло Тогда
Док = НовыйДокумент.Сотрудник.Ссылка;
ДокСотр = док.ПолучитьОбъект();
ИмяСотр = СокрЛП(РезультатЗапроса.Наименование);
ДокСотр.Сотрудник.Наименование = ИмяСотр;
Прервать;
КонецЕсли;
КонецЦикла;

НовыйДокумент.Записать();
НовыйДокумент.Автозаполнение();
НовыйДокумент.Проведен = Истина;
Попытка
НовыйДокумент.Записать();
Исключение
Сообщить("Не удалось записать объект");
Сообщить(ОписаниеОшибки());
КонецПопытки;

В обработке программно создается НовыйДокумент. В этом фрагменте я получаю объект, чтобы изменить его реквизиты, но, почему то, реквизит так и остается незаполненным. Подскажите, что тут не так?

Besart

непонятно что вы хотите изменить, справочник или документ, если документ то где вы его получаете изначально не видно, если справочник Сотрудники, то тогда ДокСотр.Записать()

Zeus_God

Спасибо. Я уже разобрался. Я неправильно получал объект. Вместо Если ТабНомСотрЧисло = КодВДокЧисло Тогда
               Док = НовыйДокумент.Сотрудник.Ссылка;
               ДокСотр = док.ПолучитьОбъект();
               ИмяСотр = СокрЛП(РезультатЗапроса.Наименование);
               ДокСотр.Сотрудник.Наименование = ИмяСотр;
               Прервать;
КонецЕсли;

Надо было написать просто Если ТабНомСотрЧисло = КодВДокЧисло Тогда
НовыйДокумент.Сотрудник = РезультатЗапроса.Ссылка;
КонецЕсли;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск