Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
14 июн 2024, 03:29

Обмен заказами 1С с сайтом!!!

Автор Himon, 26 июл 2012, 11:12

0 Пользователей и 1 гость просматривают эту тему.

Himon

Здравствуйте! Помогите пожалуйста с задачей! Необходимо чтобы при обмене заказами сайта на Битриксе и 1С 8.2 УТ 10.3 в поле комментарий (в форме заказа) попадал адрес доставки, который покупатель задает на сайте! Нашел чей-то код, который решает аналогичную задачу, расположил его также, как в работающей конфигурации:
                                             СФ_Метоположение = "";
            СФ_АдресДоставки = "";
            СФ_ДатаДоставки = "";
            СФ_ВремяДоставки = "";
            СФ_Комментарий = "";
            СФ_ТипЗаказа = "";
            СФ_МетодОплаты = "";
            СФ_СпособДоставки = "";
            Для Каждого ТоварУслугаСвойство Из Док.Строки Цикл
               
               Если НЕ ЗначениеЗаполнено(ТоварУслугаСвойство.СвойствоНаименование) Тогда
                  Продолжить;
               КонецЕсли;
               
               Если ТоварУслугаСвойство.СвойствоНаименование = "Местоположение" Тогда
                  СФ_Метоположение = ". Мест.: "+ТоварУслугаСвойство.СвойствоЗначение;
               КонецЕсли;
               Если ТоварУслугаСвойство.СвойствоНаименование = "Адрес доставки" Тогда
                  СФ_АдресДоставки = ". Адр.: "+ТоварУслугаСвойство.СвойствоЗначение;
               КонецЕсли;
               Если ТоварУслугаСвойство.СвойствоНаименование = "Желаемая дата доставки (ММ/ДД)" или ТоварУслугаСвойство.СвойствоНаименование = "Желаемая дата доставки (ДД/ММ)" Тогда
                  СФ_ДатаДоставки = ". Жел.дата: "+ТоварУслугаСвойство.СвойствоЗначение;
               КонецЕсли;
               Если ТоварУслугаСвойство.СвойствоНаименование = "Желаемое время доставки" Тогда
                  СФ_ВремяДоставки = ". Жел.время: "+ТоварУслугаСвойство.СвойствоЗначение;
               КонецЕсли;
               
               Если ТоварУслугаСвойство.СвойствоНаименование = "Тип заказа" Тогда
                  СФ_ТипЗаказа = ТоварУслугаСвойство.СвойствоЗначение;
               КонецЕсли;
               
               Если ТоварУслугаСвойство.СвойствоНаименование = "Метод оплаты" Тогда
                  СФ_МетодОплаты = ТоварУслугаСвойство.СвойствоЗначение;
               КонецЕсли;
               
               Если ТоварУслугаСвойство.СвойствоНаименование = "Способ доставки" Тогда
                  СФ_СпособДоставки = ТоварУслугаСвойство.СвойствоЗначение;
               КонецЕсли;
               
            КонецЦикла;         
            
            СФ_Комментарий = Сред(Док.ДокументОбъект.Комментарий, Найти(Док.ДокументОбъект.Комментарий, "[")-1, (Найти(Док.ДокументОбъект.Комментарий, "]")-Найти(Док.ДокументОбъект.Комментарий, "[")+2));
            Док.ДокументОбъект.Комментарий = "№ " + Док.ДокументОбъект.СФ_Номер + " Заказ с сайта " + ИмяСайта + " Инф. по доставке: " + СФ_АдресДоставки + СФ_ДатаДоставки + СФ_ВремяДоставки + СФ_Метоположение + СФ_Комментарий;

, но у меня он не работает. При перечисление свойств "ТоварУслугаСвойство.СвойствоНаименование", таких свойства как "Местоположение", "Адрес доставки" и т.д. там нет и что такое "ТоварУслугаСвойство.СвойствоНаименование" и откудо оно берется не понимаю и найти не могу. Помогите кто чем может!
P.S. "В программировании профан."

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск