Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
26 мая 2024, 21:03

Нужна помощь с гиперссылкой

Автор Salima, 27 июл 2011, 16:30

0 Пользователей и 1 гость просматривают эту тему.

Salima

Здравствуйте!!!
У меня такое дело: имеется Общая форма, на которой размещена гиперссылка для перехода на Общий макет. какой код необходимо написать в обработчик события Нажатие, чтобы при нажатии на общей форме открывался общий макет?
Подскажите пожалуйста. Заранее спасибо!
"Только смелость в прохождении пути позволяет пути показать себя!"

Dethmontt

Процедура Нажатие(Элемент)

Макет = ПолучитьОбщийМакет("ИмяМакета");

Макет.Показать();


КонецПроцедуры
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Salima

Выходит такая ошибка:

{ОбщаяФорма.Справка.Форма(5,8)}: Процедура или функция с указанным именем не определена (ПолучитьОбщийМакет)
   Макет=<<?>>ПолучитьОбщийМакет("ПроНДС"); (Проверка: Тонкий клиент)
"Только смелость в прохождении пути позволяет пути показать себя!"

Salima

Что делать если тонкий клиент?
"Только смелость в прохождении пути позволяет пути показать себя!"

Шурыгин Иван Сергеевич

писать функции препроцессору
&НаСервере
&НаКлиенте
===================================
жизнь надо прожить так, чтоб вверху посмотрели.
и сказали "А ну ка повтори"
===================================

Dethmontt

//Пример:
&НаКлиенте
Процедура Нажатие(Элемент)

мекет = ПолучитьМойМакет();

КонецПроцедуры

&НаСервере
Функция ПолучитьМойМакет()

Макетушка = ПолучитьОбщийМакет("ИмяМакета");

Возврат Макетушка;

КонецФункции
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Dethmontt

//А и на клиенте открыть его.
Макет.Показать();
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Salima

Большое спасибо вам за помощь, сделала все как указано, однако выходит следующая ошибка при нажатии на гиперссылку:
Ошибка отображения типов:
Отсутствует отображение для типа 'ОболочкаHTMLДокумента'

Более подробно выходит следующее:

{ОбщаяФорма.Справка.Форма(4)}: Ошибка при вызове метода контекста (ПолучитьМойМакет)
   Макет=ПолучитьМойМакет();
по причине:
Ошибка передачи данных между клиентом и сервером. Значение недопустимого типа.
по причине:
Ошибка преобразования данных XDTO:
Запись значения свойства 'ret':
   форма: Элемент
   имя: {http://v8.1c.ru/8.2/managed-application/modules}ret
по причине:
Ошибка отображения типов:
Отсутствует отображение для типа 'ОболочкаHTMLДокумента'
"Только смелость в прохождении пути позволяет пути показать себя!"

Dethmontt

Весь код в студию!!!
Переменная "Макетушка" имеет тип табличный документ и он серелизуется и доступен на тонком-клиенте.
Вы кажется что то там напутали
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Dethmontt

еще раз код ---
[1C]&НаКлиенте
Процедура ДекорацияНажатие(Элемент)
   
   Макет = ПолучитьМакет();
   Макет.Показать();
   
КонецПроцедуры

&НаСервереБезКонтекста
Функция  ПолучитьМакет()

   Макет = ПолучитьОбщийМакет("НовыйРелиз");
   Возврат Макет;

КонецФункции
[/1C]
Если долго всматриваться в учебник...то в голову может прийти мысль его открыть!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru

Поиск